not change the width in the incell edit mode

8 posts, 0 answers
  1. Robert
    Robert avatar
    37 posts
    Member since:
    Aug 2015

    Posted 04 Nov Link to this post

    Hi,

    We allow users to change the the value in each cells. However, the user doesn't like to see the width changes from displaying text to a textbox mode. Is there any way we can stop it so we keep the same width for the displaying text and textbox?

     

    thanks!

  2. Eyup
    Admin
    Eyup avatar
    3012 posts

    Posted 08 Nov Link to this post

    Hello Robert,

    Generally, the width should be kept the same:
    http://demos.telerik.com/aspnet-mvc/grid/editing

    Here is a live dojo sample you can experiment with and match a specific configuration:
    http://dojo.telerik.com/ayiLo

    Regards,
    Eyup
    Telerik by Progress
    Check out the new UI for ASP.NET Core, the most complete UI suite for ASP.NET Core development on the market, with 60+ tried-and-tested widgets, based on Kendo UI.
  3. UI for ASP.NET MVC is VS 2017 Ready
  4. Robert
    Robert avatar
    37 posts
    Member since:
    Aug 2015

    Posted 08 Nov in reply to Eyup Link to this post

    After some tests, I found it happens when .Scrollable(s => s.Enabled(false)). 

    However, I need to have all rows to the users and the cell width should not change in the edit mode. Is there way I can make it happens when scroll-able is false?

     

    thanks

  5. Eyup
    Admin
    Eyup avatar
    3012 posts

    Posted 10 Nov Link to this post

    Hello Robert,

    You could remove both the Scrollable and Pageable properties. However, in general this should not be a problem, as you can check in the live demo provided in my previous reply.

    If the issue remains, you can modify the dojo example to demonstrate your specific configuration and send it back to us for further investigation.

    Regards,
    Eyup
    Telerik by Progress
    Check out the new UI for ASP.NET Core, the most complete UI suite for ASP.NET Core development on the market, with 60+ tried-and-tested widgets, based on Kendo UI.
  6. Robert
    Robert avatar
    37 posts
    Member since:
    Aug 2015

    Posted 23 Nov in reply to Eyup Link to this post

    Hi Eyup,

    Sorry, I am still busy with other issues, I will try to see if I can create an empty MVC project for this. However, I could not use dojo because this happens by setting scrollable extension to false in cshtml file

    .Editable(editable => editable.Mode(GridEditMode.InCell))
    .Selectable(s => s.Enabled(true))
    .Sortable(s => s.Enabled(false))
  7. Robert
    Robert avatar
    37 posts
    Member since:
    Aug 2015

    Posted 23 Nov in reply to Robert Link to this post

    .Sortable(s => s.Enabled(false))
  8. Robert
    Robert avatar
    37 posts
    Member since:
    Aug 2015

    Posted 23 Nov in reply to Robert Link to this post

    sorry please disregard the previous codes

     

    I mean 

    .Scrollable(s => s.Enabled(false))

    or

    // .Scrollable()
  9. Eyup
    Admin
    Eyup avatar
    3012 posts

    Posted 25 Nov Link to this post

    Hello Robert,

    This is strange, indeed. If you cannot demonstrate the issue with the following dojo sample, you can open a new formal support thread to send us a runnable application:
    http://dojo.telerik.com/ayiLo/4

    Regards,
    Eyup
    Telerik by Progress
    Telerik UI for ASP.NET MVC is ready for Visual Studio 2017 RC! Learn more.
Back to Top
UI for ASP.NET MVC is VS 2017 Ready