3 posts, 0 answers
  1. Richard
    Richard avatar
    44 posts
    Member since:
    Jun 2014

    Posted 26 May 2015 Link to this post

    Hi -

    I'm suddenly getting this error on an Android project built with Eclipse that had been working fine:

    java.lang.NoClassDefFoundError: com.telerik.widget.chart.R$xml


    The project compiles but crashes when attempting to display the charts. I did merge some changes from another SVN project branch but that should not have effected the charting components. 

    Can you provide any insight into what may be wrong with my Eclipse / project configuration?




  2. Richard
    Richard avatar
    44 posts
    Member since:
    Jun 2014

    Posted 26 May 2015 in reply to Richard Link to this post

    Hi --

    I fixed this error by deleting the project folders for the charting components and copying them from the install. I then reimported them into Eclipse, compiled them all individually and then tested my app and its working.


  3. DevCraft R3 2016 release webinar banner
  4. Todor
    Todor avatar
    772 posts

    Posted 29 May 2015 Link to this post

    Hello Richard,

    I'm happy to see that you have solved your issue and thank you for sharing it with the rest of the community. We will consider this thread closed, feel free to write again if you need further assistance.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top