New version wont load

2 posts, 0 answers
  1. Stuart
    Stuart avatar
    1 posts
    Member since:
    Apr 2013

    Posted 04 Apr Link to this post

    When I logged into Telerik Control Panel this morning, it indicated that I had an older version and would need a new one. When I click the link to load the new version, I get a screen with Your Account and Products, etc. on the header, but in the middle of the screen alls it does it run through a loading graphic.  Nothing ever comes up. 


    Is there a direct download link for the new version or do you know why this is happening?  I experience the same results from IE, Chrome and FireFox.


  2. Yana
    Yana avatar
    59 posts

    Posted 06 Apr Link to this post

    Hi Stuart,

    Please accept our apologies for the inconvenience caused.

    Currently, we are experiencing an issue with the parameters of the URL we provide into the mentioned Control Panel's dialog. You can access the page without parameters on the following link. The problematic behavior is addressed to the development team which supports the web site and they are already working on it.

    I have attached file which contains the stand-alone installer of the Control Panel's latest version. 

    Could you please try to download it, unzip it, install it and let us know in case the issue still persists?

    I am looking forward to your feedback.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top