NativeScript app - Sync Error when loading to iPhone

8 posts, 0 answers
  1. Lecia
    Lecia avatar
    1 posts
    Member since:
    Feb 2015

    Posted 11 Aug 2015 Link to this post

    Right now, I'm having trouble with your Nativescript photo album tutorial.  I am using an iPhone 6 running iOS 8.4.  I JUST installed the Nativescript software on my phone and am in step 3 of the turorial where I am supposed to build the project and scan the QR code with my phone.  When I do, I get the following error  message on my phone:


    "Sync Error.  the framework versions of your project and the companion app do not match.  You might not be able to test your project in the companion app or testing might be inaccurate.  Do you want to continue?"


    As the project framework is controlled by Telerik and I JUST installed the companion app, it seems that I am limited in the debugging I can do on my end.  Can you assist on yours?
  2. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 14 Aug 2015 Link to this post

    Hello Lecia,

    This error is usually displayed if the companion app is targeting a different NativeScript version that the one your project is targeting. Can you please check the NativeScript version in your project:
    • In the Project Navigator, double-click Properties.
    • Under General check the NativeScript Version value

    If the project isn't targeting the latest supported version of NativeScript (1.1.2), use the dropdown to update the version. This operation will reload the project and will ensure that the NativeScript modules are updated accordingly. Then you should be able to successfully test the app's behavior in the companion app.

    Note that even if you don't update the NativeScript targeted version, you would still be able to run your app in the companion app although I wouldn't recommend building a project with an outdated NativeScript version.

    Let me know if you have any further questions on developing apps with NativeScript in AppBuilder.

    Regards,
    Tina Stancheva
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  3. Tigga
    Tigga avatar
    5 posts
    Member since:
    Feb 2015

    Posted 22 Nov 2015 in reply to Tina Stancheva Link to this post

    Hi,

    I followed the instructions, and changed my application from 1.2.3 to 1.4.3. I was warned that this requires removing the tns_modules directory and "App_Resources\Android\values*\styles.html" from your project and modifying your package.json file to include the required dependencies. I replied OK. I also removed and re-installed AppBuilder on my iPhone. I still get the mismatched framework error. Under dependencies I see tns-core-modules is 1.4.0. Is that appropriate? What else can I do?

     

    Hunter

  4. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 26 Nov 2015 Link to this post

    Hi Hunter,

    I wasn't able to replicate the issue with the Photo Album Native code sample created though the Photo Album tutorial. As long as the NativeScript version is 1.4.3, I don't get the NativeScript app nitofication for mismatched versions.

    Can you please submit a support ticket, where we can keep the communication private and you can share your project so I can test its behavior in the companion app on my side. Thank you in advance for your cooperation.

    Regards,
    Tina Stancheva
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  5. Tigga
    Tigga avatar
    5 posts
    Member since:
    Feb 2015

    Posted 09 Dec 2015 in reply to Tina Stancheva Link to this post

    I love to open a ticket. How do I do that?
  6. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 10 Dec 2015 Link to this post

    Hi Hunter,

    I've noticed you submitted a ticket but I'll post the information for the community.

    In order to submit a ticket for Telerik Platform, you can use these steps:
    • Log in Telerik Platform
    • Click on your name at the top right corner of the screen
    • Select Get Support
    • Click the Submit Support Ticket under Telerik Platform.
    You can also examine the support plans available for each subscription in the comparison table here.

    Regards,
    Tina Stancheva
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  7. Tigga
    Tigga avatar
    5 posts
    Member since:
    Feb 2015

    Posted 20 Dec 2015 in reply to Tina Stancheva Link to this post

    Hi,

    Very bad new. I opened a ticket. Support ID:994146 -- Migrate fails in Firefox.

    1) I Installed Chrome

    2) I ran the migration on "ShopScheduleII" and it ran without giving an error.

    3) NOW MY CODE IS GONE. All of it. I have a blank app. I tried to revert - and I did revert back - but not to the pre-migration application.

     

     Please, can someone restore the ShopScheduleII app to the way it was prior to the migration? I think I did the migration December 19th. There was a lot of code - and my only backup  is on vacation in China.

    Hunter


     
     
  8. Tsvetina
    Admin
    Tsvetina avatar
    1873 posts

    Posted 23 Dec 2015 Link to this post

    Hi Hunter,

    I replied to your support ticket which describes this problem. We will help you restore the application, but we need a little more information from you. You can provide it to us in the support thread where we asked you a couple of questions.

    Regards,
    Tsvetina
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top