Maintaining Site using OpenAccess 2010.2.714.1 using Visual Studio 2012

7 posts, 0 answers
  1. richardFlow
    richardFlow avatar
    62 posts
    Member since:
    Jun 2012

    Posted 08 Feb 2013 Link to this post

    Hi,

    I am maintaining a website that uses version 2010.2.714.1 of OpenAccess. Since upgrading to Visual Studio 2012 I haven't been able to access the reverse mapping wizard, the menu does not appear like it did in VS2010. I have tried reinstalling OpenAccess but this didn't fix the problem.

    How can I resolve this?

    Thanks,
    Richard
  2. TSE
    TSE avatar
    381 posts
    Member since:
    Sep 2008

    Posted 12 Feb 2013 Link to this post

    Hi Richard,

    If you are referring to the old reverse mapping you must enable it in the Telerik-OpenAccess->Options menu->Enable old.....

    Regards

    Henrik
  3. DevCraft banner
  4. richardFlow
    richardFlow avatar
    62 posts
    Member since:
    Jun 2012

    Posted 12 Feb 2013 Link to this post

    Hi Henrik,

    The problem is that I can't get the Telerik OpenAccess menu to appear in Visual Studio 2012.
    It worked fine in 2010 and I could select the reverse mapping option as you described.

    Screengrab

    Thanks,
    Richard
  5. Ivailo
    Admin
    Ivailo avatar
    318 posts

    Posted 12 Feb 2013 Link to this post

    Hi Richard,

    The compatibility with the final release of Visual Studio 2012 was introduced in the more recent releases of Telerik OpenAccess ORM - Q2 2012 SP2 and later. 

    Our recommendation would be to migrate to the latest release of OpenAccess - Q3 2012 SP1 or the one we are about to release next week - Q1 2013. Using them you should be able to work with Visual Studio 2012 without any issues. 

    I hope that helps. 

    All the best,
    Ivailo
    the Telerik team
    Q3'12 SP1 of OpenAccess ORM packs Multi-Table Entities mapping support. Check it out.
  6. richardFlow
    richardFlow avatar
    62 posts
    Member since:
    Jun 2012

    Posted 14 Feb 2013 Link to this post

    Is there no way to make the current version I have work?
    My company doesn't pay for an OpenAccess subscription any more so I can't download a later version.
    We're just maintaining a web site that has been developed using 2010.2.714.1

    .

  7. richardFlow
    richardFlow avatar
    62 posts
    Member since:
    Jun 2012

    Posted 18 Feb 2013 Link to this post

    Sorry, I didn't realise that OpenAccess is a free product now!
    Downloaded the new version, so hopefully that will sort me out.
    Thanks for your help.
  8. Ivailo
    Admin
    Ivailo avatar
    318 posts

    Posted 19 Feb 2013 Link to this post

    Hi Richard,

    Indeed, OpenAccess ORM is already free so you can always download the latest version. Have in mind that this week we are releasing the Q1 2013 version that includes even more interesting new features, so you might want to check it out. 

    Kind regards,
    Ivailo
    the Telerik team
    Q3'12 SP1 of OpenAccess ORM packs Multi-Table Entities mapping support. Check it out.
Back to Top
DevCraft banner