Localhost traffic being modified, capturing even when I turn that off

4 posts, 0 answers
  1. Robert
    Robert avatar
    2 posts
    Member since:
    Apr 2014

    Posted 02 Apr 2014 Link to this post

    I installed Fiddler to view the traffic to/from a local application via http://localhost:8888/.. I installed Fiddler 4.4.6.2 but am a bit confused by a couple of things.

    When I run my test that accesses my app (on http://localhost:8888/.. ) I see the traffic in Fiddler, but the client I am testing crashes because it seems to be getting back something from Fiddler Echo Service instead of the actual response from my app. How do I stop that?

    Secondly, even when I turn capturing off (File > Capture Traffic), it is still capturing traffic. I have to exit from Fiddler before it stops.

    Is there something else I am meant to do here just to get Fiddler to view the traffic, not modify it, and to stop capturing when I ask?

    Thanks!

    Rob
    :)
  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 03 Apr 2014 Link to this post

    Hello, Robert--

    Fiddler is a proxy server that runs on your PC. Your app isn't running at localhost:8888, Fiddler is running on that port. You should access your application using its URL, instead of using the host:port that Fiddler is running on.

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. Robert
    Robert avatar
    2 posts
    Member since:
    Apr 2014

    Posted 03 Apr 2014 in reply to Eric Lawrence Link to this post

    Hi Erik,

    Well, that explains the response I was getting. Can we change Fiddler's port? Because my app is actually running on port 8888 and I would rather not change that.

    I guess that explains why I thought it was capturing traffic even when I turned that off - because Fiddler took over the port my app needs!

    Rob
    :)
  4. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 04 Apr 2014 Link to this post

    Hi,

    Click Tools > Fiddler Options > Connections to change the port Fiddler runs on. I must warn you, however, that port 8888 has other contenders which make it a dubious choice; see https://groups.google.com/forum/#!topic/httpfiddler/-Ja4L_tezOc

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top