List Box appears disabled after 2014 Q3 upgrade

2 posts, 0 answers
  1. Arockia J
    Arockia J avatar
    13 posts
    Member since:
    Mar 2010

    Posted 05 Dec 2014 Link to this post

    Dear Team,

    We upgraded our Telerik to the 2014 Q3 build. Further to upgrade, we found that the Rad List Box appears to be in disable state whichever skin we apply for it. As per our application, we render our control via partial post back inside an user control. We also tested for the same by isolating this control to a separate aspx page. While rendering, we noted errors thrown in the Javascript FireBug console (please see attached).

    Attachment #1: TelerikProblem.png (taken from FireBug console)
    Attachment #2: TelerikInside.png (taken from the screen that appeared when clicking the error on the FireBug console).

    This happens only for Rad List Box whereas there is no issue with other controls.

    This happens in Google Chrome & IE also.

    On Google chrome, the console error read as follows

    Telerik RadListBox Cannot read property 'Classic' of undefined

    We tried different render modes, still the same occurs.

    Kindly let us if we are missing something.

    Thanks and Regards,

    Arockia J
  2. Dimitar Terziev
    Dimitar Terziev avatar
    1266 posts

    Posted 08 Dec 2014 Link to this post


    In order to troubleshoot this issue, please specify whether the embedded scripts are disabled and you are manually loading the scripts via the RadScriptManager or not. I have prepared a sample page implementing a similar scenario as the one describe in your post, and there is no issue at my side.

    Dimitar Terziev

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

  3. DevCraft R3 2016 release webinar banner
Back to Top