Jet database engine error when data source used

4 posts, 1 answers
  1. Rob
    Rob avatar
    8 posts
    Member since:
    Sep 2010

    Posted 11 Nov 2010 Link to this post

    I'm getting the following error when I run any test with a data source in Visual Studio. I have no problem creating or running alone but when I have VS run the tests, these all fail. My machine is running Windows 2008 SP2 64 bit. I have verified the items and paths are present and have even recreated mutiple times.

    '11/11/2010 2:07:05 PM' - Unexpected exception during execution.
    '11/11/2010 2:07:05 PM' - System.Data.OleDb.OleDbException (0x80040E37): The Microsoft Jet database engine could not find the object 'TestDocs$'.  Make sure the object exists and that you spell its name and the path name correctly.
       at System.Data.OleDb.OleDbCommand.ExecuteCommandTextErrorHandling(OleDbHResult hr)
       at System.Data.OleDb.OleDbCommand.ExecuteCommandTextForSingleResult(tagDBPARAMS dbParams, Object& executeResult)
       at System.Data.OleDb.OleDbCommand.ExecuteCommandText(Object& executeResult)
       at System.Data.OleDb.OleDbCommand.ExecuteCommand(CommandBehavior behavior, Object& executeResult)
       at System.Data.OleDb.OleDbCommand.ExecuteReaderInternal(CommandBehavior behavior, String method)
       at System.Data.OleDb.OleDbCommand.ExecuteReader(CommandBehavior behavior)
       at System.Data.OleDb.OleDbCommand.System.Data.IDbCommand.ExecuteReader(CommandBehavior behavior)
       at System.Data.Common.DbDataAdapter.FillInternal(DataSet dataset, DataTable[] datatables, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior)
       at System.Data.Common.DbDataAdapter.Fill(DataTable[] dataTables, Int32 startRecord, Int32 maxRecords, IDbCommand command, CommandBehavior behavior)
       at System.Data.Common.DbDataAdapter.Fill(DataTable dataTable)
       at ArtOfTest.Common.Design.Data.ExcelDataSource.GetData(DataInfo testBindingInfo)
       at ArtOfTest.WebAii.Design.Execution.DataContext.InitializeDataSource(String outDirectory)
       at ArtOfTest.WebAii.Design.Execution.ExecutionContext.SetCurrentTestAndData(Test test)
       at ArtOfTest.WebAii.Design.Execution.TestExecuteProxy.ExecuteTest(Test test, Settings settings, String deploymentFolder, ExecutionType exeType, Int32 lastStepIndex, IntPtr& hwnd)

  2. Answer
    Cody avatar
    3360 posts

    Posted 11 Nov 2010 Link to this post

    Hello Rob,

    Are you using Visual Studio 2010? Microsoft change the default for Enable Deployment in this new version to be disabled by default. Verify it is enabled as shown in the attached screen shot.

    1. Open your .testsettings file (found in the Solution Items folder)
    2. Click Deployment on the left
    3. Check Enable deployment

    Now run your test again and see if this problem happens again.

    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Rob
    Rob avatar
    8 posts
    Member since:
    Sep 2010

    Posted 12 Nov 2010 Link to this post

    Thanks a lot Cody, that resolved the issue
  4. Deepak
    Deepak avatar
    2 posts
    Member since:
    Dec 2011

    Posted 11 Mar 2012 Link to this post

    To resolve defined issue, follow below steps.
    - Compile build with X 86 processes.

    How to do this:
    - open test project Properties.
    - Build
    - platform Target = x86. 


Back to Top
  Cast Your Vote at DevPro Connections! Cast Your Vote at  Win IT Pro Connections!