Issue with kendo ui mobile view

7 posts, 0 answers
  1. Sarvesh
    Sarvesh avatar
    9 posts
    Member since:
    Mar 2015

    Posted 16 Apr 2015 Link to this post

    Hi,

     

    Kendo ui mobile view displays the background color without  the content when initially loading the application on some mobile devices (eg :motorola)

    but works fine on mobile devices like(Micromax canvas 2 colours)

      

    Regards,

    Sarvesh

  2. Sarvesh
    Sarvesh avatar
    9 posts
    Member since:
    Mar 2015

    Posted 19 Apr 2015 Link to this post

    Hi,

     

    Any solution for the above mentioned issue?

    If the user taps the screen the view contents become visible.

     

    Regards,

    Sarvesh

  3. Martin Yankov
    Admin
    Martin Yankov avatar
    177 posts

    Posted 20 Apr 2015 Link to this post

    Hi Sarvesh,

    Is there a chance you are running on an older version of Kendo UI Mobile? If yes, please try your app with the latest version and let me know if the problem solves. Also, please share the Android OS that the two devices are running on and the Motorola model. This sounds like a problem with the Android 2.3 web view.

    Regards,
    Martin Yankov
    Telerik
     

    See What's Next in App Development. Register for TelerikNEXT.

     
  4. Sarvesh
    Sarvesh avatar
    9 posts
    Member since:
    Mar 2015

    Posted 20 Apr 2015 in reply to Martin Yankov Link to this post

    Hi Martin,

    I am using the latest version of kendo ui mobile.

    Micromax : Android version 4.4.2

    Moto E : Android version 4.4.4

     

    Regards,

    Sarvesh

  5. Martin Yankov
    Admin
    Martin Yankov avatar
    177 posts

    Posted 21 Apr 2015 Link to this post

    Hi Sarvesh,

    This is a very odd behavior. Can you please provide a sample app that I can use to reproduce the issue on my side and investigate it?

    Thanks in advance for the cooperation.

    Regards,
    Martin Yankov
    Telerik
     

    See What's Next in App Development. Register for TelerikNEXT.

     
  6. Sarvesh
    Sarvesh avatar
    9 posts
    Member since:
    Mar 2015

    Posted 22 Apr 2015 in reply to Martin Yankov Link to this post

    Hi Martin,

    This issue is seen also with  kendo ui demo examples (eg.  http://demos.telerik.com/kendo-ui/mobile-listview/index). If the user taps the screen or changes the orientation after the app loads ,the view content become visible.

     

    Regards,

    Sarvesh

     

  7. Martin Yankov
    Admin
    Martin Yankov avatar
    177 posts

    Posted 23 Apr 2015 Link to this post

    Hi Sarvesh,

    I cannot reproduce this on my side. Most probably, there is a problem with the web view on the device you are testing with. Unfortunately, we cannot control all the web view variations the different device manufacturers use. That is why we are looking into providing ways to overwrite the default device web view for hybrid apps and unify the app experience on all devices. With its next release in early May AppBuilder will provide Cordova 4.0 support which lets you change the web view the app runs on.

    Let me know if you have any other questions.

    Regards,
    Martin Yankov
    Telerik
     

    See What's Next in App Development. Register for TelerikNEXT.

     
Back to Top