iOS Cordova camera API performance issue?

2 posts, 1 answers
  1. Jari
    Jari avatar
    5 posts
    Member since:
    Sep 2011

    Posted 10 Feb 2015 Link to this post

    Hi All,

    I am running the code in the tutorials where in the Step 5, we used Cordova camera API to capture picture.

    In my testing using iPhone 6, iOS 8.1.3, I tried to take around 10 photos, after 3 or 4 photos, the button will not response right away.
    I.e. you need to click it several times before the camera show up.

    You can test by clicking the Add button, show camera, and cancel. Do it 3, or 4 times and this will happen.

    This raises a concern as I need to evaluate Icenium to make a decision if I should go with Icenium or doing a Native iOS app.

    Anybody can help me with this issue, or did I do something wrong causing this?

    Thank you,

  2. Answer
    Kaloyan avatar
    871 posts

    Posted 13 Feb 2015 Link to this post

    Hi Jari,

    Thank you for writing. I can see that you have also submitted a support ticket on the matter. There, I can see that you have found a solution in using our Camera sample.

    Further, we will investigate what could be causing the faulty behavior in our tutorial and will try to fix it for future Telerik Platform releases.

    I hope this sounds okay. Please, let me know if we can be of a further assistance.


    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

Back to Top