Installed new just trace version, can't type open square brackets in VS 2010.

4 posts, 0 answers
  1. Andrea
    Andrea avatar
    52 posts
    Member since:
    Oct 2012

    Posted 29 Jul 2013 Link to this post

    Using italian keyboard layout i have to type ALTGR+è to get [ symbol.

    Just trace bound a shortcut to same key JustTrace.PerformanceProfiler (CTRL+ALT+è) .

    As workaround I disabled all just trace shortcuts from Tools > Options > Environment > Keyboard .



  2. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 30 Jul 2013 Link to this post

    Hi Andrea,

    Thank you for reporting this.

    It is hard to find shortcuts inside Visual Studio that can be bound without overriding something else :). We believe the ones we are using for enabling the profilers (Ctrl + Alt + ' and Ctrl + Alt + ;) are one of the least used when it comes to Visual Studio addons and extensions. However, as you have reported, it is possible for conflicts to arise.

    Disabling our shortcuts should solve the issue, yet you can also replace them with anything you will find appropriate for your environment. This can be done from the same window (Tools > Options > Environment > Keyboard) by adding new shortcuts for the JustTrace commands.

    I hope this helps.

    Regards,
    Kaloyan
    Telerik
    Share what you think about JustTrace & JustMock with us, so we can become even better! You can use the built-in feedback tool inside JustTrace, our forums, or our JustTrace or JustMock portals.
  3. DevCraft banner
  4. Florent
    Florent avatar
    1 posts
    Member since:
    Dec 2012

    Posted 22 Aug 2013 Link to this post

    Thanks I was going totally crazy !!!!! (swiss french keyboard same probleme)

    btw I don't understand why u set a shortcut to start JustTrace...For me it's a bit useless.
  5. Martin
    Admin
    Martin avatar
    29 posts

    Posted 26 Aug 2013 Link to this post

    Hi Florent,

    I am glad that the problem is resolved.

    Since the latest internal builds of JustTrace and JustMock all shortcuts now use Alt+Shift instead of Ctrl+Shift which unfortunately collided with ALTGR shortcuts on some localized keyboards.

    Regards,
    Martin
    Telerik
    Share what you think about JustTrace & JustMock with us, so we can become even better! You can use the built-in feedback tool inside JustTrace, our forums, or our JustTrace or JustMock portals.
Back to Top