Icons on iOS not deploying and unable to remove icons from project.

8 posts, 0 answers
  1. Michael Rogers
    Michael Rogers avatar
    22 posts
    Member since:
    Mar 2010

    Posted 15 Nov 2012 Link to this post

    I'm using a provisioning profile to test our app on an iPhone 4S and two different ipads.  When I run the app on the phone and ipad the icon that is installed is one of the spash screens.  I've tried to add them to the project again to see if that helps with no luck.  You are not able to delete icons for iOS devices in the project properties.  When you click on the x it doesn't do anything.

    Thanks
    Michael
  2. Yavor Georgiev
    Admin
    Yavor Georgiev avatar
    982 posts

    Posted 16 Nov 2012 Link to this post

    Hi Michael,

     Can you please tell me whether you are using Graphite or Mist?

    Greetings,
    Yavor Georgiev
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  3. Michael Rogers
    Michael Rogers avatar
    22 posts
    Member since:
    Mar 2010

    Posted 16 Nov 2012 Link to this post

    Graphite 
  4. Michael Rogers
    Michael Rogers avatar
    22 posts
    Member since:
    Mar 2010

    Posted 16 Nov 2012 Link to this post

    I did a build with Mist also and get the same result.

    Thanks
    Michael
  5. Yavor Georgiev
    Admin
    Yavor Georgiev avatar
    982 posts

    Posted 16 Nov 2012 Link to this post

    Hello Michael,

     In order to change the icons your iOS app will display you need to do the following:
    1. Open your project in Graphite and open its Properties view
    2. Navigate to the iOS tab to the left
    3. Expand the "iPhone Icons" section
    4. For each size of the icon you'd like to change, hover over the image and click the upload button that will appear. Select an image you'd like to use from your computer in the Open File dialog. The icon should be replaced with the image your chose.
    5. Repeat the same in the "iPad Icons" section

    All the best,
    Yavor Georgiev
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  6. Michael Rogers
    Michael Rogers avatar
    22 posts
    Member since:
    Mar 2010

    Posted 16 Nov 2012 Link to this post

    I have preformed these steps.  I've selected all of the icons for a second time and when i deploy it to the device i still have the splash screen as the icon.  I have deleting the app to make sure, still same result.  I can only build with Mist right now since I'm getting a Robocopy error with Graphite so i can't try it with that.  I have another post about that though.

    Thanks
    Michael
  7. Kristina
    Admin
    Kristina avatar
    57 posts

    Posted 19 Nov 2012 Link to this post

    Hello Michael,

     Would you please check if the DPI of your images is 96? Currently there is a problem with our image resizing algorithm and if the DPI is different than 96, it would produce wrong dimension calculations. If you change the images DPI to 96 everything should be working fine.

     Please contact us if you have any problems.


    Greetings,
    Kristina
    the Telerik team

    Share feedback and vote for features on our Feedback Portal.
    Want some Kendo UI online training - head over to Pluralsight.
  8. Michael Rogers
    Michael Rogers avatar
    22 posts
    Member since:
    Mar 2010

    Posted 19 Nov 2012 Link to this post

    That fixed it, the images were all 72dpi.  

    Thanks
    Michael
Back to Top