HTTPS traffic capturing

6 posts, 0 answers
  1. GURDARSHAN SINGH
    GURDARSHAN SINGH avatar
    4 posts
    Member since:
    Sep 2014

    Posted 22 Sep 2014 Link to this post

    When I am trying to capture traffic of my website that deployed over HTTPS protocol along with proxy configuration in my local network, system throw following error. I have tried all possible setting in Tools -> Fiddler Option -> HTTPS and Connection but nothing work:

    [Fiddler] The connection to the upstream proxy/gateway failed. Closing Fiddler, changing your system proxy settings, and restarting Fiddler may help. 
    System.Exception Upstream Gateway refused requested CONNECT.


    Please help me in fixing this problem, as I need to record some performance matrix for my website.
  2. GURDARSHAN SINGH
    GURDARSHAN SINGH avatar
    4 posts
    Member since:
    Sep 2014

    Posted 22 Sep 2014 in reply to GURDARSHAN SINGH Link to this post

    Along with given error on checking Request header following error message in Request header:

    Fiddler - Gateway Connection Failed
  3. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 22 Sep 2014 Link to this post

    When Fiddler isn't running, what are your proxy settings inside Internet Explorer's Tools > Options > Connections > LAN Settings?

    What, if any, text do you see on Fiddler's LOG tab?

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  4. GURDARSHAN SINGH
    GURDARSHAN SINGH avatar
    4 posts
    Member since:
    Sep 2014

    Posted 23 Sep 2014 in reply to GURDARSHAN SINGH Link to this post

    When Fiddler isn't running, what are your proxy settings inside Internet Explorer's Tools > Options > Connections > LAN Settings?
    <Guru> Please see attached screen shot LanSetting.jpg for detail about this point.

    What, if any, text do you see on Fiddler's LOG tab?

    See below log tab detail:

    -= Fiddler Event Log =-

    10:55:07:6796 fiddler.network.connect2> Upstream gateway demanded proxy authentication, which is not supported in this scenario. HTTP/1.1 407 authenticationrequired
    Via: 1.1 10.227.1.250 (McAfee Web Gateway 7.3.2.10.0.17592)
    Content-Type: text/html
    Cache-Control: no-cache
    Content-Length: 2830
    Proxy-Connection: Close
    Proxy-Authenticate: NTLM
    Proxy-Authenticate: Basic realm="Ad
  5. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 23 Sep 2014 Link to this post

    When you say "capture traffic of my website" what exactly do you mean? The error you encountered should only ever be seen if Fiddler itself is generating requests, and not if a web browser or other client generates the request. If a client other than Fiddler generates the request, it should automatically handle a HTTP/407 response by returning credentials for the proxy.

    In the scenario where Fiddler generates the request, it doesn't today have a means to prompt you for credentials. You can, however, supply those credentials by clicking in the black QuickExec box below the Web Sessions list and typing

       prefs set fiddler.composer.HTTPSProxyBasicCreds yourusername:yourpassword

    ...and hitting Enter. Fiddler will then apply those credentials when generating CONNECT tunnels to your authenticating proxy.

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  6. GURDARSHAN SINGH
    GURDARSHAN SINGH avatar
    4 posts
    Member since:
    Sep 2014

    Posted 23 Sep 2014 in reply to Eric Lawrence Link to this post

    Thanks Eric,

    It's awesome, you solution works but not sure why this is happening this way, as request is send from browser only and Fiddler just catching each request.

    BTW, thanks for your support.

    Regards,
    Guru
Back to Top