Handling Message box

2 posts, 0 answers
  1. Siva
    Siva avatar
    28 posts
    Member since:
    Apr 2012

    Posted 08 Aug 2013 Link to this post

    Hi


      I got record messagebox says "OK", But Handle Alert Dislog some times working well executed, but some time it stays for longtime ( screen display with that message box), i have to click ok then it will proceed to the next recorded step for execution.

    how to overcome this, it is annoying an my test get failed if i don't click ok manually.

    Help appreciated
    Thanks
  2. Boyan Boev
    Admin
    Boyan Boev avatar
    1045 posts

    Posted 12 Aug 2013 Link to this post

    Hello Siva,

    I am sorry to hear you are running into this problem.

    Please try to add an WaitForExists step for the button you are clicking on. You also insert some execution delay just before the handling step.

    If the issue persists please:

    1. Send us the execution log.

    2. Please record a Jing video demonstrating the entire process, so we can better understand what is happening. 

    3. Please provide us with a copy of your test and if it is possible grant us access to your application so we can reproduce the issue on our end and give you a solution. If it is not possible to grant us access to your application, please take a Fiddler trace and attach it to a support ticket in a zip file. You can capture a Fiddler trace using FiddlerCap.

    Hope to hear from you soon. 

     

    Regards,
    Boyan Boev
    Telerik
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
Back to Top