General Feedback

2 posts, 0 answers
  1. ofer
    ofer avatar
    6 posts
    Member since:
    May 2014

    Posted 19 Jun 2015 Link to this post

    I've been using the Appbuilder for roughly a month now. I'm excited that I can work from OSX and Windows; however, the amount of bugs present in the simulator, especially when using "Developer tools", outweigh the benefit of actually using the platform to build applications. Overall, if I prototype by "right clicking" and editing live properties on the simulator, I can expect my device simulator to crash within 2-5 minutes of changes. 

    I'm not sure why this is acceptable with a production level app that users pay for. This platform's QA and dev quality would appear to suffer greatly from inner workings of Telerik's Appbuilder dev team. Much of this should have been tested more thoroughly, and users should not be charged for the constant instability of the application. I'm not able to be productive with constant simulator crashes. 

    This is an opportunity to open a world iOS dev to the world being executed poorly. I really want this to work well, but my impressions are that the Ionic framework's stability is much greater than what Telerik has built on top of it. 

  2. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 24 Jun 2015 Link to this post

    Hello Ofer,

    I am sorry to see you are experiencing such issues and I can understand your frustration as they slow you down. I am afraid that we are not aware of such a case specifically - you can check all known issues within the AppBuilder Windows client here. Under the hood, the AppBuilder Windows client device simulator uses Chromium Embedded Framework (CEF) and we are currently in the process of updating its version. We will release the updated version by the end of the year and it might improve the behavior of the simulator on your side.

    However, as I cannot replicate this behavior locally, I cannot further investigate it and narrow it down. This is why I cannot confirm whether any changes we implement with our next releases will improve this behavior. I would therefore appreciate it if you can take a moment and provide us with more information so we can investigate the issue on our side:
    • Which AppBuilder client are you using
    • On what OS are you seeing the issue
    • Does the simulator crashes when working on one particular project
    • Can you send us a project where we can try to replicate the issue as well as the steps we can follow
    • Please zip the contents of the %localappdata%\Telerik\BlackDragon\Logs folder and send them over - we need to check whether there are any errors logged by the simulator or the dev tools
    Once we have the above information, we will investigate the case further and I will be able to provide you with more information on its cause and our plans for addressing it.

    In the meantime, you can also try using the native emulators to examine your app's behavior on a device or deploy your app directly on a device, where you can also debug and modify the app as it is running.

    Regards,
    Tina Stancheva
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top