Fiddler not capturing traffic

5 posts, 0 answers
  1. Boone
    Boone avatar
    3 posts
    Member since:
    Jan 2012

    Posted 19 Jun 2014 Link to this post

    I've been using Fiddler for years, but the most recent version I've installed (v4.4.8.4) no longer captures any traffic.

    - The Filters are turned off (and using the "Troubleshoot Filters" doesn't appear to change anything)
    - Traffic does not appear in Fiddler when I visit http://ipv4.fiddler:8888
    - However, traffic *does* appear when I visit http://localhost:8888

    Does anyone have a suggestion?

    Thanks.
  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 19 Jun 2014 Link to this post

    Hello, Boon--

    The symptoms described indicate that Fiddler is listening properly and it isn't blocked by a firewall. However, they also suggest that your system's proxy settings are not getting set correctly.

    You can manually look at your proxy settings by clicking Tools > WinINET Options > LAN Settings while Fiddler is "Capturing". These should be pointed at 127.0.0.1:8888 but based on your description, they probably aren't.

    There are a few possibilities:

    1> You are on a corporate network where the IT Administrator has used Group Policy to enforce a particular proxy. The WinINET options will typically show a yellow banner if that's the case.

    2> You have some other software installed which is interfering with the system proxy setting. Some security software or VPN software will constantly overwrite the proxy settings.

    3> Your system has some configuration problem where the proxy settings are not properly being persisted. You can try setting the proxy setting to address 127.0.0.1 and port 8888 yourself, click "Ok" and see if the settings "stick."

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. Boone
    Boone avatar
    3 posts
    Member since:
    Jan 2012

    Posted 24 Jun 2014 in reply to Eric Lawrence Link to this post

    Yes, I think you identified it perfectly. It appears that my company is setting specific proxy settings that I cannot override.

    FWIW, the only workaround that I was able to find was to run Chrome (my browser of choice) with a command-line option of: --proxy-server=127.0.0.1:8888

    This forces a proxy for that instance of Chrome and lets me start capturing Fiddler traffic again.
  4. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 24 Jun 2014 Link to this post

    Hi, Boone--

    Yes, if Group Policy is in use, the IE proxy settings are "locked" from modification by normal users. If you are an admin on your PC (a user with Administrative Group permissions) you can right-click Fiddler and choose "Run as Administrator." When you do this, Fiddler should be able to (temporarily) overwrite the system's proxy settings.

    As you noted, Chrome (as well as Firefox) can have their proxy settings manually adjusted independently from the system settings.

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  5. Boone
    Boone avatar
    3 posts
    Member since:
    Jan 2012

    Posted 25 Jun 2014 in reply to Eric Lawrence Link to this post

    I appreciate the suggestion, but that didn't seem to work for me.

    I am an administrator on my PC. However, even if I run Fiddler as an administrator, the proxy settings don't persist.

    At least I seem to have a workaround with using the Chrome command-line options. It's not perfect, but it looks like my Group Policy might not give me a better option.

    Thanks
Back to Top