Feature Data Reports have no data

4 posts, 0 answers
  1. Graham Wade
    Graham Wade avatar
    4 posts
    Member since:
    Nov 2009

    Posted 18 Jul 2013 Link to this post

    Hi, I am logging data and if I drill down into sessions can see the features used within that session. If I select any of the feature data reports there is no data. I just get the "Missing data?" prompt. Any ideas of what I have to do in order to get data into these reports.
  2. Rasmus
    Admin
    Rasmus avatar
    4 posts

    Posted 19 Jul 2013 Link to this post

    Hello Graham,

    By default, incoming data does not appear on the dashboard until the next day. You can change this behavior by clicking the “live” button in the lower right corner near the dashboard period slider. That will show you live, incoming data on the dashboard itself. The data may 5 minutes delayed due to processing.

    I hope this helps. Otherwise please don’t hesitate to write us again. Include a screenshot if possible, it makes is easier understanding of the problem.

    Regards,
    Rasmus
    Telerik
    JAVASCRIPT MONITOR (BETA) AVAILABLE FOR DOWNLOAD.
    Monitor web applications with the new EQATEC Application Analytics JS library. Compatible with all modern browsers.
    Test it today >>
  3. Graham Wade
    Graham Wade avatar
    4 posts
    Member since:
    Nov 2009

    Posted 19 Jul 2013 Link to this post

    Found the problem for the Feature Use report. When you open the page there is a grey banner with a small up arror on the left and the "missing data?" prompt. You have to click on the arrow in order to see the report. Other pages display the data by default and you have to close those that you don't want. Still no data on the "Feature Timing" and "Feature Value" reports.
  4. Rasmus
    Admin
    Rasmus avatar
    4 posts

    Posted 19 Jul 2013 Link to this post

    Hi Graham,

    I can see you not have any categories in your feature use name. Therefore you will get the grey banner, because its empty.
    When you track a feature use you can use the . (dot) to separate category name from the feature name. Like in this example. Where you will get a category called "export":  
    monitor.TrackFeature("export.file");

    See more in our getting started guide: http://www.telerik.com/analytics/resources/getting-started

    We have not registered any feature value or feature timing on our server. We have separated api calls for feature use, feature timing (start / stop), feature values. 

    If you have further questions then don't hesitate to contact us.
    Regards,
    Rasmus
    Telerik
    JAVASCRIPT MONITOR (BETA) AVAILABLE FOR DOWNLOAD.
    Monitor web applications with the new EQATEC Application Analytics JS library. Compatible with all modern browsers.
    Test it today >>
Back to Top