Extra unwanted quotation mark

5 posts, 0 answers
  1. Larry
    Larry avatar
    1 posts
    Member since:
    Nov 2013

    Posted 21 Jun 2015 Link to this post

    I've had a long-standing issue where in a "cshtml" file (an MVC View), whenever I type a double quote mark, it supplies me with TWO additional quote marks for a total of THREE, instead of the one extra as you'd expect.  I'm not sure whether this is being done by Visual Studio itself, by JustCode, or perhaps some other add-in.  I don't see any way to disable JustCode short of uninstalling it.  A Telerik forum post says that you can disable the add-in, but when I go there, the Disable button is greyed out and the tool-tip says that it can't be disabled.

    I've found that by unchecking the "Automatic Brace Completion" option in the HTML language section for Visual Studio that the quote then works correctly (type one, get two), but then you also lose the "auto-closing" feature for single brace, bracket, and parenthesis as well.

    I don't believe that any other add-ins or extensions I have are doing any code formatting so I think it has to be either VS itself or JustCode.

    Anybody experienced this or have any ideas?

  2. Svetlozar
    Admin
    Svetlozar avatar
    271 posts

    Posted 25 Jun 2015 Link to this post

    Hi,

    I am really sorry for the inconvenience!

    We will try to reproduce the issue on our side. Meanwhile, you can try to disable JustCode and see if the issue gets resolved. You can do that from JustCode menu | Help | Disable JustCode.

    Let us know if JustCode is responsible for the behavior on your side.

    Regards,
    Svetlozar
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. DevCraft banner
  4. Steve
    Steve avatar
    2 posts
    Member since:
    Sep 2015

    Posted 10 Nov 2015 in reply to Svetlozar Link to this post

    I'm having the same problem. If I disable JustCode and the problem goes away. So definitely a JustCode issue.

    However, I do want to use JustCode, so leaving it disabled is not a real solution.

  5. Svetlozar
    Admin
    Svetlozar avatar
    271 posts

    Posted 13 Nov 2015 Link to this post

    Hi,

    I am really sorry for the inconvenience!

    Could you please clarify what version of Visual Studio do you use? Do you by any chance have the Typing Assistance feature turned on? You can check it from JustCode Options | Typing Assistance | C# | Use Typing Assistance. Please note that we don't have that feature for Visual Studio 2015.


    Regards,
    Svetlozar
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. Steve
    Steve avatar
    2 posts
    Member since:
    Sep 2015

    Posted 13 Nov 2015 in reply to Svetlozar Link to this post

    Visual Studio 2013.

    Yes, I had Typing Assistance turned on.

    Problem solved by turning JustCode Typing Assistance off and turning Brace Completion on in Visual Studio.

Back to Top
DevCraft banner