extra <DIV> tag in the bullet list creation in theTelerik Editor

9 posts, 0 answers
  1. Chuck
    Chuck avatar
    18 posts
    Member since:
    Apr 2014

    Posted 25 Feb 2015 Link to this post

    Telerik Product version: 2014.1.403.40

    There is an issue of extra <DIV> tag inserted into the HTML code during the bullet list creation in theTelerik Editor. It is preventing the user from adding addition bullet entry in the bullet list. (See attached doc Steps to reproduce the extra.png for the steps to reproduce the issue. This is a Word docx. Please rename it docx extension to open it).

    Thanks,
    Chuck
    Wolters Kluwer/UpToDate Inc.
  2. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 27 Feb 2015 Link to this post

    Hi Chuck,

    The situation seems to me quite related to the initial content inserted. Although, via the snapshots, I can only make guesses to what the content exactly is.

    Please provide the content used. Also, I suggest you trying to reproduce the same using this online demo. If the same issue is reproducible there, please get back with the exact steps to reproduce. If it is not, you can try if upgrading to a more recent version of the RadEditor will fix the issue.

    Any further details, that would help me recreate the issue locally, will let me further investigate the reason for the issue's appearance.

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Chuck
    Chuck avatar
    18 posts
    Member since:
    Apr 2014

    Posted 03 Mar 2015 in reply to Ianko Link to this post

    Hi Ianko,

    I'm pretty sure the extra tag or tag attribute (such as telerik_insertedList_id") inserted into the editor's html source is not caused by our application code. Here is another example: random extra attribute added for the <ol> or <ul> tag (see attachment). I'm wondering does the telerik editor is behaving different if it is running with HTML quirks mode. 

    Thanks,
    Chuck
  5. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 05 Mar 2015 Link to this post

    Hello Chuck,

    In the first post, the telerik_insertedList_id value is not mentioned or shown in the MS Word file. Also, with the snapshots attached, I am still unable to locally examine the HTML that is used as initial content, and thus, unable to investigate the situation. 

    Please, collaborate more on the case and provide some details about the RadEditor configuration and the HTML content used, so to be able to understand the scenario accurately.

    As for the quirks mode, no, the RadEditor does not implement different logic when the browser is in quirks mode. Although, the browser does. Quirks mode, is just like using IE5, and therefore, it is not supported with recent versions of the UI for ASP.NET AJAX.

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  6. Chuck
    Chuck avatar
    18 posts
    Member since:
    Apr 2014

    Posted 06 Mar 2015 in reply to Chuck Link to this post

    Hi Ianko,

    Here are the Editor toolbar configuration file, and initial content source (html template load from the template manager) to load into the editor. It is an intermittent problem. It may not happen right away but will show up eventually after editing and affect our production output data.
    Thanks,

    Chuck
  7. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 10 Mar 2015 Link to this post

    Hi Chuck,

    I am unable to view the images. It appears that they are broken. Could you please reattach them as zip file.

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  8. Chuck
    Chuck avatar
    18 posts
    Member since:
    Apr 2014

    Posted 10 Mar 2015 in reply to Ianko Link to this post

    Hi Ianko,

    Here is the zip file (ChuckEditor.zip.gif) for the initial content load and the telerik toolbar xml. Please rename ChuckEditor.zip.gif to ChuckEditor.zip before unzip it.

    Thanks,
    Chuck
  9. Chuck
    Chuck avatar
    18 posts
    Member since:
    Apr 2014

    Posted 10 Mar 2015 in reply to Chuck Link to this post

    Hi Ianko,

    Here is the zip file (ChuckEditor.zip.gif) for the initial content load and the telerik toolbar xml. Please rename ChuckEditor.zip.gif to ChuckEditor.zip before unzip it.

    Thanks,
    Chuck
  10. Ianko
    Admin
    Ianko avatar
    1535 posts

    Posted 13 Mar 2015 Link to this post

    Hi Chuck,

    I am afraid, this is not related to the initial content either. You can see my test in this screencast. As you can see, none of the NewLineModes, neither insert list command causes the described behavior. Due to that, I am unable to define what the might be and why it occurs on your end. 

    I suggest isolating the scenario in a locally runnable sample and provide it, so to be able to examine it properly. 

    On a side note, zip archives can be attached, so please, do not modify the extensions, just attach plain zip archives with the files inside.

    Regards,
    Ianko
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017