Error Rendering/Creating Control

4 posts, 0 answers
  1. Rick
    Rick avatar
    33 posts
    Member since:
    Mar 2014

    Posted 02 Dec 2014 Link to this post

    My apologies for posting a question that may have already been answered.  I've searched multiples times and none of the solutions apply to my situation.

    I am receiving this error when I open my default.aspx page immediately after creating the project.  I have not changed any code at all.

    I get Error Rendering Control for RadScriptManager
    I get Error Creating Control for RadAjaxManager

    Could not load file or assembly ‘Telerik.Web.UI, Version 2014.3.1024.45, Culture=neutral,
    PublicKeyToken=121fae7816bda3d4’ or one of its dependencies.  The located assembly’s manifest definition
    does not match the assembly reference. 
    (Exception from HRESULT: 0x80131040)

    I've updated the Telerik Suite since I first had this issue and I still have the issue on newly created projects.

    <%@ Page Language="VB" AutoEventWireup="false" CodeBehind="Default.aspx.vb" Inherits="GenericBrowser._Default" %>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "">
    <head runat="server">
        <telerik:RadStyleSheetManager id="RadStyleSheetManager1" runat="server" />
        <form id="form1" runat="server">
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
                <asp:ScriptReference Assembly="Telerik.Web.UI" Name="Telerik.Web.UI.Common.Core.js" />
                <asp:ScriptReference Assembly="Telerik.Web.UI" Name="Telerik.Web.UI.Common.jQuery.js" />
                <asp:ScriptReference Assembly="Telerik.Web.UI" Name="Telerik.Web.UI.Common.jQueryInclude.js" />
        <script type="text/javascript">
            //Put your JavaScript code here.
        <telerik:RadAjaxManager ID="RadAjaxManager1" runat="server">

    <?xml version="1.0"?>
            <add key="Telerik.ScriptManager.TelerikCdn" value="Disabled" />
            <add key="Telerik.StyleSheetManager.TelerikCdn" value="Disabled" />
            <compilation debug="false" strict="false" explicit="true" targetFramework="4.5.1" />
            <httpRuntime targetFramework="4.5.1" />
                    <add tagPrefix="telerik" namespace="Telerik.Web.UI" assembly="Telerik.Web.UI" />
                <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false" />
                <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
                <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
                <add path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" validate="false" />
                <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
                <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule" />
                <add name="RadCompression" type="Telerik.Web.UI.RadCompression" />
            <validation validateIntegratedModeConfiguration="false" />
            <modules runAllManagedModulesForAllRequests="true">
                <remove name="RadUploadModule" />
                <add name="RadUploadModule" type="Telerik.Web.UI.RadUploadHttpModule" preCondition="integratedMode" />
                <remove name="RadCompression" />
                <add name="RadCompression" type="Telerik.Web.UI.RadCompression" preCondition="integratedMode" />
                <remove name="ChartImage_axd" />
                <add name="ChartImage_axd" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" preCondition="integratedMode" />
                <remove name="Telerik_Web_UI_SpellCheckHandler_axd" />
                <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode" />
                <remove name="Telerik_Web_UI_DialogHandler_aspx" />
                <add name="Telerik_Web_UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode" />
                <remove name="Telerik_RadUploadProgressHandler_ashx" />
                <add name="Telerik_RadUploadProgressHandler_ashx" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" preCondition="integratedMode" />
                <remove name="Telerik_Web_UI_WebResource_axd" />
                <add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode" />
  2. Rick
    Rick avatar
    33 posts
    Member since:
    Mar 2014

    Posted 03 Dec 2014 in reply to Rick Link to this post

    Resolved - Had to add the control to the GAC.  This article helped which I did find by doing yet another search.

    Now I have to figure out why I don't have the Telerik Toolbox
  3. DevCraft R3 2016 release webinar banner
  4. Pavlina
    Pavlina avatar
    6070 posts

    Posted 05 Dec 2014 Link to this post


    I recommend you examine the article below which elaborates on how to resolve toolbox problems:


    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

  5. Rick
    Rick avatar
    33 posts
    Member since:
    Mar 2014

    Posted 10 Dec 2014 in reply to Pavlina Link to this post

    Thank you.  I deleted the TBD files and after rebooting it worked.
Back to Top