DSW with ORM 2010 Q1. Object reference not set.

36 posts, 0 answers
  1. Missing user
    Missing user avatar

    Posted 21 Jun 2010 Link to this post

    Hello James,

    Actually I was referring to an internal build which is not public yet, sorry for not clarifying that. You can expect this build in a couple of days.

    Best wishes,
    Rizk Sobhi
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  2. Christian
    Christian avatar
    81 posts
    Member since:
    Aug 2008

    Posted 25 Jun 2010 Link to this post

    Hi,
    I ran in the same issue after installing ORM 2010 Q1 (0527). I use VS 2010 and have a class modell project and a winform project. My app.config have a <connectionStrings>-section.

    Here same information from the output:

    Calling: "c:\program files (x86)\telerik\openaccess orm\sdk\VEnhance.exe" -assembly:"C:\Projekte\PADUA\Kerndaten\obj\Debug\ZentraleDaten.dll" -config:"C:\Projekte\PADUA\Kerndaten\App.config" -verboseMode:1

    OpenAccess: C:\Projekte\PADUA\Kerndaten\obj\Debug\ZentraleDaten.dll: Error: Could not resolve: Telerik.OpenAccess.35.Extensions, Version=2010.1.527.2, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342

    Telerik OpenAccess Enhancer, Version 2010.1.527.2

    Copyright (C) 1996-2010 Telerik

    C:\Projekte\PADUA\Kerndaten\obj\Debug\ZentraleDaten.dll: Error: Could not resolve: Telerik.OpenAccess.35.Extensions, Version=2010.1.527.2, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342



    I need a workaround, because our team project stands still.

    Thanks.
    Christian
  3. DevCraft banner
  4. Alexander
    Admin
    Alexander avatar
    727 posts

    Posted 25 Jun 2010 Link to this post

    Hello Christian,

    Could you please try the new service pack that we released yesterday? Its version is 2010.1.624. Please let us know if it does not help.

    Kind regards,
    Alexander
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  5. Christian
    Christian avatar
    81 posts
    Member since:
    Aug 2008

    Posted 25 Jun 2010 Link to this post

    Hi,
    thanks. It's fine now.
    Christian.
  6. Niall
    Niall avatar
    1 posts
    Member since:
    Jun 2012

    Posted 17 Jul 2012 Link to this post

    Hi,

    I'm trying to generate the code to reflect changes we've made to our database.
    The product is quite mature and we've been making changes recently which we've struggled to refliect via Telerik Open Access ORM because it is unbelievably unreliable and processor intensive, but until now I have been able to eventually generate the code to reflect the changes.

    I've just made some very minor changes to the data model adding a new FK to a table but the DSW now gives the "Object reference not set to an instance of an object" error when I click "save and generate".

    I've uninstalled and re-installed and restarted several, times now, but the problem persists.
    My colleague has tried to generate the code as well, but he gets the same error so the problem seems to be with Telerik.

    Versions are 2010.1.312

    Thanks, Niall...
  7. Serge
    Admin
    Serge avatar
    375 posts

    Posted 20 Jul 2012 Link to this post

    Hello Niall,

     Unfortunately I am unable to reproduce the exception that you are experiencing. Is switching to a newer version of OpenAccess and making use of the new Add OpenAccess Service wizard an option? If you insinst on using the version you have though, is it possible that we get the model containing your project or just the rlinq so that we can test it locally. It is quite possible the issue is only reproducable with certain kinds of mappings. 

    I am looking forward to resolving this issue. 

    Kind regards,
    Serge
    the Telerik team
    OpenAccess ORM Q2'12 Now Available! Get your hands on all the new stuff.
Back to Top
DevCraft banner