DisplayUpFolder not working

4 posts, 0 answers
  1. Digant
    Digant avatar
    13 posts
    Member since:
    Dec 2013

    Posted 13 Aug 2014 Link to this post

    I have set DisplayUpFolderItem to true in my projects...But it is not working.
    I have used AssemblyQualifiedName as my ContentProviderTypeName and has overrided ResolveDirectory as well as ResolveRootDirectoryAsTree.

    Please help.
  2. Vessy
    Admin
    Vessy avatar
    1380 posts

    Posted 13 Aug 2014 Link to this post

    Hi Digant,

    I tested the DisplayUpFolderItem but it is functioning properly on my side. Can you please provide more details on the specific scenario you are using the FileExplorer control?
    •  Which version of the controls is used in your application?
    • In which browser and its version does the issue occur?
    • Could you verify that you are testing the DisplayUpFolderItem functionality over inner folders, but not the root directory?
    • Does the property function properly in you are using the built-in FileExplorer's provider? If so - could you send us your custom provider so we could examine it?

    It would be really helpful if you isolate the problem into a very simplified fully runnable project  so we could replicate and examine it on our side.


    Looking forward to hearing from you,
    Vessy
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Digant
    Digant avatar
    13 posts
    Member since:
    Dec 2013

    Posted 14 Aug 2014 in reply to Vessy Link to this post

    Version : 2013.2.717.40
    Browser : IE10
    Yeah, I am testing DisplayUpFolderItem functionality over inner folders.

    I didn't got your last point about "property function properly in you are using the built-in FileExplorer's provider".

  5. Vessy
    Admin
    Vessy avatar
    1380 posts

    Posted 18 Aug 2014 Link to this post

    Hi Digant,

    Please, accept my apologies for not being clear enough in my previous reply.

    By saying "Does the property function properly if you are using the built-in FileExplorer's provider?" I wanted to know what is the FileExplorer's behavior when the DisplayUpFolderItem property is configured, but your custom content provider is not assigned. In this way you will know what is the FileExplorer's behavior with its built-in content provider, and so whether your custom one is changing this functionality.

    Additionally, I have tested the control with with the used by you version in IE10, but still was not able to reproduce the problematic behavior on my side. I will need to reproduce the issue on my side and the examine the exact configuration that is causing it in order to provide any further assistance on the matter, so my request about a simplified fully runnable project  still applies.

    Looking forward to hearing from you,
    Vessy
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
Back to Top