Disabling the Show Animation for RadWindow in Q2

7 posts, 0 answers
  1. Neil
    Neil avatar
    10 posts
    Member since:
    Apr 2011

    Posted 25 Oct 2011 Link to this post

    I'm trying to disable the slide-in animation for the RadWindow in Telerik Q211. Setting AnimationSelector to null or an empty animation selector has no effect. Setting IsAnimationEnabled to false has no effect. The animation is too slow on slow machines, so we really need to disable it. Here is our style - I know its correctly applied as it has a lovely HotPink background.

    <Style TargetType="telerikNavigation:RadWindow" x:Key="RadWindowStyle">
          <Setter Property="IsRestricted" Value="true"/>
          <Setter Property="IsTabStop" Value="false" />
          <Setter Property="Background" Value="HotPink" />
          <Setter Property="BorderBrush" Value="{StaticResource WindowOuterBorder}" />
          <Setter Property="BorderBackground" Value="{StaticResource WindowBorderBackground}" />
          <Setter Property="ModalBackground" Value="{StaticResource WindowModalBackground}" />
          <Setter Property="BorderThickness" Value="5 0 5 5" />
          <Setter Property="MinHeight" Value="26" />
          <Setter Property="MinWidth" Value="100" />
          <Setter Property="HorizontalContentAlignment" Value="Stretch" />
          <Setter Property="VerticalContentAlignment" Value="Stretch" />
          <Setter Property="Header" Value="RadWindow" />
          <Setter Property="HeaderTemplate" Value="{StaticResource HeaderTemplate}"/>
          <Setter Property="WindowStartupLocation" Value="CenterOwner" />
          <Setter Property="WindowState" Value="Normal" />
          <Setter Property="Template" Value="{StaticResource RadWindowTemplate}" />
          <Setter Property="TabNavigation" Value="Cycle" />
          <Setter Property="animation:AnimationManager.IsAnimationEnabled" Value="False"/>
          <Setter Property="animation:AnimationManager.AnimationSelector" Value="{x:Null}"/>
        </Style>
  2. Miroslav Nedyalkov
    Admin
    Miroslav Nedyalkov avatar
    1718 posts

    Posted 26 Oct 2011 Link to this post

    Hi Neil,

    The RadWindow control doesn't have a slide-in animation, but a fade-in animation. Setting the AnimationSelector to null should stop this animation. Could you please share some more details on this matter - a video that shows this slide-in animation would help us a lot.

    All the best,
    Miroslav Nedyalkov
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. DevCraft banner
  4. Neil
    Neil avatar
    10 posts
    Member since:
    Apr 2011

    Posted 26 Oct 2011 Link to this post

    I've attached a project http://www.mediafire.com/file/t7w1aalacb7kpay
     which shows the slide in behaviour.


    I've used the Window Styles from our real application. 


    To simulate other activity (to slow down the animation) I spawn 16 threads that sit and do something intensive but boring in the background.


    The background for the app is a giant button - Click it and you should see the animation in (over 2-3 frames usually). You might not see it every time, so you may need to repeat to see the animation.

    Any information would be very valuable.
  5. Miroslav Nedyalkov
    Admin
    Miroslav Nedyalkov avatar
    1718 posts

    Posted 26 Oct 2011 Link to this post

    Hello Neil,

    What you are observing is not an animation, but the window is changing its size as the image is loaded after the RadWindow is shown as it needs some time to download. To prevent this behavior you need to set Width and Height either to the Image or to the RadWindow control.

    Hope this helps.

    Regards,
    Miroslav Nedyalkov
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  6. Neil
    Neil avatar
    10 posts
    Member since:
    Apr 2011

    Posted 26 Oct 2011 Link to this post

    The image was purely for something visual to show in the window. The same thing occurs if I have an empty Border (Fixed size) in there. 

    Replace the <Image> with

       <Border Width="300" Height="300" Background="HotPink" BorderBrush="Purple" BorderThickness="4"/>

    And see the same thing. 
  7. Miroslav Nedyalkov
    Admin
    Miroslav Nedyalkov avatar
    1718 posts

    Posted 27 Oct 2011 Link to this post

    Hello Neil,

    There was a visual glitch in the RadWindow control related to the WindowStartupLocation property - the was centered incorrectly and centered once again later. This might look an animation if the machine is slow or loaded. This problem was fixed in the latest internal build, but wasn't included in the 2011 Q3 beta version. Could you please try either the latest internal build or to set the WindowStartupLocation property to Manual and tell us does this problem still exist?

    Best wishes,
    Miroslav Nedyalkov
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  8. Neil
    Neil avatar
    10 posts
    Member since:
    Apr 2011

    Posted 27 Oct 2011 Link to this post

    Unfortunately we've tried the Q3 release and we are due to release soon and had many issues with it which we couldn't track down in time for release. We will try again after we've released I suppose.
Back to Top
DevCraft banner