Devcraft Suite Installation issue

6 posts, 0 answers
  1. Nagarjuna
    Nagarjuna avatar
    2 posts
    Member since:
    Sep 2010

    Posted 12 Jun 2013 Link to this post

    I am trying to test Devcraft Suite. I have issues installing the product - I am behind proxy and I did provide the credetials, but it didn't work with both options - using Internet proxy settings as well as providing direct proxy settings with authentication details during install.

    If there is a full install file for this, I would appreciate. We are able to install RadControls for ASP.NET AJAX and test these fine.Following is the error:

    ValidationVersion.xml from ProductInfoService. ---> System.Net.WebException: The remote server returned an error: (407) Proxy Authentication Required. at System.Net.HttpWebRequest.GetResponse() at Telerik.CommonInstaller.ProductInfoService.ProductInfoService.DeserializeRemoteObject[T](String sourceUri, String sourceName) --- End of inner exception stack trace --- at Telerik.CommonInstaller.ProductInfoService.ProductInfoService.DeserializeRemoteObject[T](String sourceUri, String sourceName) at Telerik.CommonInstaller.ProductInfoService.ProductInfoService.get_WebInstallerValidationVersion() at Telerik.CommonInstaller.Application.Services.DeprecationService.GetWebInstallerMinVersion() at Telerik.CommonInstaller.Application.Services.DeprecationService.CheckWebInstallerDeprecated() at Telerik.CommonInstaller.WebInstaller.App.CheckIsDeprecated() at Telerik.CommonInstaller.InstallerUIBase.ApplicationBase.OnStartup(StartupEventArgs e) at Telerik.CommonInstaller.WebInstaller.App.OnStartup(StartupEventArgs e) at System.Windows.Application.<.ctor>b__0(Object unused) at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Boolean isSingleParameter) at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Boolean isSingleParameter, Delegate catchHandler)
  2. msigman
    msigman avatar
    141 posts
    Member since:
    Apr 2008

    Posted 14 Jun 2013 Link to this post

    Yes you can download the installer manually.  Follow these steps:

    Log in > Click "Your Account" (upper right corner of screen) > Products & Subscriptions (upper right also) > DevCraft Ultimate > Download
  3. DevCraft R3 2016 release webinar banner
  4. Nagarjuna
    Nagarjuna avatar
    2 posts
    Member since:
    Sep 2010

    Posted 14 Jun 2013 Link to this post

    I do not see that option - DevCraft Ultimate, in my Products & Subscriptions. Attached is the pic of what I see. Thanks!
    Admin avatar
    1 posts

    Posted 17 Jun 2013 Link to this post

    Hi Nagarjuna,

    Thank you for reaching out. I believe Matthew had replied on the assumption that you had a purchased license in your account- my apologies on the mix up.

    Currently, you have a DevCraft Ultimate trial license which has expired back in November 2010. Do you know if there is a purchased license you can use? Alternatively, could you pull down a new trial of our product offering?

    This will allow you to evaluate the latest version of our components as there have been several releases since 2010.

    I'd like to introduce the Global Sales Rep for Fannie Mae, Andrew Hamilton- cc'd here. Should you have any questions do not hesitate to reach out.


    Inda C
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  6. steven
    steven avatar
    19 posts
    Member since:
    Aug 2014

    Posted 21 Aug 2014 Link to this post

    I just purchased a DevCraft edition and after following the instructions I attempted to install the software, but neither of the products will install and I get an error that some file or assembly was not found.

    How do I install the products?

    System.IO.FileNotFoundException: Could not load file or assembly 'Telerik.StandaloneUtils, Version=, Culture=neutral, PublicKeyToken=602a9bfd8c8c4ad7' or one of its dependencies. The system cannot find the file specified.
    File name: 'Telerik.StandaloneUtils, Version=, Culture=neutral, PublicKeyToken=602a9bfd8c8c4ad7'

  7. Marin Bratanov
    Marin Bratanov avatar
    3555 posts

    Posted 22 Aug 2014 Link to this post

    Hi Steven,

    I have edited out the profanity from your post because we do not tolerate such language here.

    On the installation issue - I am really sorry to hear you are having difficulties with this, and since this is not an error we have ever encountered before, it looks like it is something quite specific to the concrete machine.

    The Telerik.StandaloneUtils assembly is a part of our installer, so when the installer runs it is extracted to the %temp% folder in a directory with a random name, in order to be available. Since it cannot be found by the program, this means that it is not in that folder and there can be numerous reasons for that. The ones I can think of are:

    • The user account that is used does not have sufficient permissions to write or read from this folder. If possible, try running the installers as administrator.
    • Some security software (e.g., antivirus program), blocks, quarantines or deletes the assembly for some reason. I can assure you that it is not harmful, so you can add an exception for it or temporarily suspend the program.

    Since at this point we are only guessing, in case the above ideas do not help, you can go to your account and download and run the standalone *.msi installers for the individual products: In the end, both the control panel and the web installer do the same.


    Marin Bratanov

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

Back to Top
DevCraft R3 2016 release webinar banner