Default Shortcut Keys Overridden

6 posts, 1 answers
  1. Mark Olson
    Mark Olson avatar
    2 posts
    Member since:
    Dec 2009

    Posted 11 Dec 2009 Link to this post

    I'm having a good time checking out all the features in JustCode and it seems like a great tool.  But I was annoyed that some default Visual Studio 2008 shortcut keys had been overridden.

    Specifically, Ctrl+UpArrow and Ctrl+DownArrow

    I use these to scroll my page without moving my cursor regularly, but now it looks for my next error (typically in files that are supposed to be excluded from the project [.exclude file extension]), and I can't figure out how to remap those shortcut keys, or remove the JustCode shortcuts for those particular functions.

    Regards, Mark.
  2. Answer
    Kaloyan
    Admin
    Kaloyan avatar
    82 posts

    Posted 14 Dec 2009 Link to this post

    Hi Mark,

    Thanks for the involvement.

    There's a way to fix the behavior you observe. From Tools->Options->Environment->Keyboard options page you can adjust VS & JustCode keyboard shortcut the way it suits you. If you type "JustCode" in the "Show commands containing:" text field, you'll get all JustCode commands with their keyboard shortcuts.The ones you're looking for are "JustCode.GotoNextError" and "JustCode.GotoPreviousError". When you select one of the commands you can customize its keyboard mapping. In our case you can just choose the shortcut you want to remove from the drop-down list ("Shortcuts for selected command:") and hit Remove. Then you'll need to assign a shortcut for the original VS commands which are "Edit.ScrollLineUp" and "Edit.ScrollLineDown". That should do the trick. In case at some point you want to use the original JustCode shortcuts you can do so by going to JustCode->Options->General options page and pressing the "Restore keyboard shortcuts" button on the top of the page, which will overwrite the VS settings and restore JustCode ones.

    Let us know if that works for you.

    Regards,
    Kaloyan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. DevCraft banner
  4. Mark Olson
    Mark Olson avatar
    2 posts
    Member since:
    Dec 2009

    Posted 15 Dec 2009 Link to this post

    Kaloyan, That worked great, thank you.  I'm back to using my familiar shortcuts and being very happy with JustCode.

    Thanks for the help.
    Mark.
  5. Michael
    Michael avatar
    84 posts
    Member since:
    May 2008

    Posted 17 Dec 2009 Link to this post

    I really really hate JustCode's ctrl-click of text. I want ctrl-click to highlight the whole word instead of navigating to the class etc. Is there a way to fix that?
  6. Kaloyan
    Admin
    Kaloyan avatar
    82 posts

    Posted 17 Dec 2009 Link to this post

    Hello Michael,

    There's an option in the menu JustCode->Options dialog. In the General options page there is a check box that manages the behavior you mention - "Go to definition on <Ctrl + Left Click> in editor". If you clear that option you'll get the default VS action for Ctrl+Click, i.e. highlighting word under cursor.

    Kind regards,
    Kaloyan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  7. Brendan
    Brendan avatar
    1 posts
    Member since:
    Sep 2012

    Posted 06 Sep 2012 Link to this post

    Ideally, the ctrl-click on text should only apply on mouseup (not mousedown). Then, only execute "navigate to" if the mouse stayed within some minimum distance. If they moved the mouse more than X amount, then they are attempting to select the word/words underneath.
Back to Top
DevCraft banner