Crashes VS2008

18 posts, 0 answers
  1. Michael Josiah
    Michael Josiah avatar
    92 posts
    Member since:
    Nov 2007

    Posted 18 Nov 2009 Link to this post

    Hi guys

    The beta version appears to be crashing out my VS2008. Any ideas why?
  2. Brian H. Madsen
    Brian H. Madsen avatar
    18 posts
    Member since:
    Nov 2008

    Posted 18 Nov 2009 Link to this post

    Give us some repro steps or ideas as to when it crashes and we could take a look at it...

    what are you doing when it crashes? the more details the better..
  3. DevCraft banner
  4. Michael Josiah
    Michael Josiah avatar
    92 posts
    Member since:
    Nov 2007

    Posted 18 Nov 2009 Link to this post

    Hi Brian

    Here are my steps. Please note the environment is VS2008 on Windows 7 Ulitmate

    1) Make sure VS2008 is closed
    2) Install Justcosde
    3) Run VS2008
    4) It crashes

    Hope this helps. Please let me know if there is any other bits of info I can get over to you.


  5. Ivo Bratoev
    Admin
    Ivo Bratoev avatar
    107 posts

    Posted 18 Nov 2009 Link to this post

    Hi Michael,
    Thank you for your feedback.
    To help you with your problem, I will need some additional information. Could you please check your desktop for a file with the name "justcode-crashlog.txt". If there is such a file, please send it to us.

    Regards,
    Ivo Bratoev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Michael Josiah
    Michael Josiah avatar
    92 posts
    Member since:
    Nov 2007

    Posted 18 Nov 2009 Link to this post

    Hi

    I could not find the file you mentioned. However when vs2008 crashed on startup again I was able to copy the description of the error.

    Problem signature:
      Problem Event Name: CLR20r3
      Problem Signature 01: devenv.exe
      Problem Signature 02: 9.0.30729.1
      Problem Signature 03: 488f2b50
      Problem Signature 04: System.ServiceModel
      Problem Signature 05: 3.0.0.0
      Problem Signature 06: 4a174dd6
      Problem Signature 07: 628d
      Problem Signature 08: 8
      Problem Signature 09: System.ArgumentException
      OS Version: 6.1.7600.2.0.0.256.1
      Locale ID: 2057

    Does this help at all? Or is there something else I can get over to you.
  7. Michael Josiah
    Michael Josiah avatar
    92 posts
    Member since:
    Nov 2007

    Posted 18 Nov 2009 Link to this post

    Please note, its not Justcode crashing but rather Justcode crashing VS2008. Probably explains why I could not see the file you mentioned earlier. Still awaiting some response on this issue as I am very eager to start using it.

    Thanks
  8. Chris
    Admin
    Chris avatar
    221 posts

    Posted 18 Nov 2009 Link to this post

    Hello Michael,
    Can you please install this VS hotfix and see whether the problem persists?
    http://support.microsoft.com/default.aspx?scid=kb;en-us;963676&sd=rss&spid=8291

    If this doesn't help could you go the following folder on your machine:

    (for Windows XP):
    C:\Documents and Settings\[Your Username]\Local Settings\Application Data\JustCode\Logs

    (for Windows Vista / 7):
    C:\Users\[Your Username]\AppData\Local\JustCode\Logs

    and send us the last modified file? I'm sorry for the inconvenience.

    Greetings,
    Chris
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  9. Michael Josiah
    Michael Josiah avatar
    92 posts
    Member since:
    Nov 2007

    Posted 18 Nov 2009 Link to this post

    Hi the log reads the following

    INFO 2009-11-18 16:58:39.632 : JustCode Version: 2009.3.1117.5
    INFO 2009-11-18 16:58:39.664 : VS Version: 9.0
    INFO 2009-11-18 16:58:48.961 : Resetting menus
  10. Brian H. Madsen
    Brian H. Madsen avatar
    18 posts
    Member since:
    Nov 2008

    Posted 19 Nov 2009 Link to this post

    @Michael,

    I can't seem to reproduce the problem you're having.

    suggestion, if the above hot-fix didn't sort it out.

    turn off all other add-ins you might be running - then turn them back on, one at a time, as it could easily be something from another add-in that's conflicting with JustCode loading.

    If you're not running any other add-in, then try re-installing JustCode or repairing VS2008.

    "Doesn't work on my machine".

    Cheers,
    Brian H. Madsen
    Microsoft MVP ASP.Net
  11. Dyt Iscus
    Dyt Iscus avatar
    9 posts
    Member since:
    Jul 2005

    Posted 20 Nov 2009 Link to this post

     

     

    fdHello,
    I have a similair problem here. When I am in the codebehind and hover over a colored block of Justcode on the right of the texteditor VS2008 crashs with the following error:

     

    Problem signature:  
    Problem Event Name: CLR20r3  
    Problem Signature 01: devenv.exe  
    Problem Signature 02: 9.0.30729.1  
    Problem Signature 03: 488f2b50  
    Problem Signature 04: PresentationCore  
    Problem Signature 05: 3.0.0.0  
    Problem Signature 06: 4a174f97  
    Problem Signature 07: 3acc  
    Problem Signature 08: 39  
    Problem Signature 09: System.InvalidOperationException  
    OS Version: 6.1.7600.2.0.0.256.48  
    Locale ID: 1043 

    JustCode.log  
    INFO 2009-11-20 09:08:45.587 : JustCode Version: 2009.3.1117.5  
    INFO 2009-11-20 09:08:45.685 : VS Version: 9.0  
    INFO 2009-11-20 09:09:02.250 : Resetting menus  
    INFO 2009-11-20 09:35:54.344 : Solution initialization started.  
    INFO 2009-11-20 09:35:55.012 : Started engine service process id 952  
    INFO 2009-11-20 09:35:57.250 : Server (952): Code analysis process started.  
    INFO 2009-11-20 09:35:57.445 : Server (952): Code analysis service is ready.  
    INFO 2009-11-20 09:35:57.538 : Connection to engine service elapsed: 2555  
    INFO 2009-11-20 09:36:00.940 : Solution initialization completed.  
    INFO 2009-11-20 09:36:09.810 : Registering solution!  
    INFO 2009-11-20 09:46:16.287 : Server (952): Callback channel faulted. Exiting server. 

    I am working with VS2008 on Windows7 so the kb article is not helping me much...
    Thanks!

  12. Ivo Bratoev
    Admin
    Ivo Bratoev avatar
    107 posts

    Posted 20 Nov 2009 Link to this post

    Hello Michael,
    We just released a new internal build of JustCode. You can get it here. Please test with this version. If you still have the same problem, could you check for the previously mentioned JustCode logs and send it to us.
    You are the only one with this problem (at least from the reports so far), so it was a good suggestion to check your other addins for possible conflicts as Brian suggested.
    We are determined to solve this issue.

    Regards,
    Ivo Bratoev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  13. Ivo Bratoev
    Admin
    Ivo Bratoev avatar
    107 posts

    Posted 20 Nov 2009 Link to this post

    Hello Dyt,
    The problem you experience seems to be different from Michael's. Michael's Visual Studio crashes on startup.
    To fix the problem you reported I will need a bit more information:
    1. By "codebehind", do you mean the codebehind of an ASP.NET page?
    2. Does the problem occur every time for you?
    3. Can you hover over errors in the error stripe bar in a regular code file?

    Thank you for your help!

    Greetings,
    Ivo Bratoev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  14. Dyt Iscus
    Dyt Iscus avatar
    9 posts
    Member since:
    Jul 2005

    Posted 20 Nov 2009 Link to this post

    Hello,

    As you can read above Michael is not the only one with crashes...
    I tried the the latest build and still get crashes although a different one.
    I haven't installed other addons then the default vs2008 and TFS addons. I work on Windows7
    Tried it on my vista machine where Justcode is running fine (both versions).

    Here is the logfile.
    INFO 2009-11-20 17:39:41.811 : JustCode Version: 2009.3.1120.13  
    INFO 2009-11-20 17:39:41.817 : VS Version: 9.0  
    ERROR 2009-11-20 17:40:07.787 : System.InvalidOperationException: An unspecified error occurred on the render thread.  
       at System.Windows.Media.MediaContext.NotifyPartitionIsZombie(Int32 failureCode)  
       at System.Windows.Media.MediaContext.NotifyChannelMessage()  
       at System.Windows.Interop.HwndTarget.HandleMessage(Int32 msg, IntPtr wparam, IntPtr lparam)  
       at System.Windows.Interop.HwndSource.HwndTargetFilterMessage(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)  
       at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)  
       at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)  
       at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Boolean isSingleParameter)  
       at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Boolean isSingleParameter, Delegate catchHandler)  
       at System.Windows.Threading.Dispatcher.WrappedInvoke(Delegate callback, Object args, Boolean isSingleParameter, Delegate catchHandler)  
       at System.Windows.Threading.Dispatcher.InvokeImpl(DispatcherPriority priority, TimeSpan timeout, Delegate method, Object args, Boolean isSingleParameter)  
       at System.Windows.Threading.Dispatcher.Invoke(DispatcherPriority priority, Delegate method, Object arg)  
       at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam)  
       at MS.Win32.UnsafeNativeMethods.DispatchMessage(MSG& msg)  
       at System.Windows.Threading.Dispatcher.PushFrameImpl(DispatcherFrame frame)  
       at System.Windows.Threading.Dispatcher.PushFrame(DispatcherFrame frame)  
       at System.Windows.Window.ShowHelper(Object booleanBox)  
       at System.Windows.Window.Show()  
       at System.Windows.Window.ShowDialog()  
       at Telerik.JustCode.UserInterface.Commands.ShowAboutDialogCommand.Execute(IJustCodeServiceContainer serviceContainer) in c:\B\Manticore\Production\Sources\source\UserInterface\Commands\ShowAboutDialogCommand.cs:line 82  
       at Telerik.JustCode.JustCodeApplication...„(DynamicCommand _) in c:\B\Manticore\Production\Sources\source\JustCode.Application\JustCodeApplication.cs:line 16777215  
       at Telerik.JustCode.Services.VSCommandService.ExecuteDynamicCommand(String vsCmdName) in c:\B\Manticore\Production\Sources\source\JustCode.Application\Services\VSCommandService.cs:line 146  
    Log Site Stacktrace:  
       at Telerik.JustCode.Common.Logger.(Exception ex) in c:\B\Manticore\Production\Sources\source\Common\Logger.cs:line 261  
       at Telerik.JustCode.Common.Logger.LogException(Exception ex, String message) in c:\B\Manticore\Production\Sources\source\Common\Logger.cs:line 93  
       at Telerik.JustCode.Common.Logger.LogException(Exception ex) in c:\B\Manticore\Production\Sources\source\Common\Logger.cs:line 77  
       at Telerik.JustCode.Services.VSCommandService.ExecuteDynamicCommand(String vsCmdName) in c:\B\Manticore\Production\Sources\source\JustCode.Application\Services\VSCommandService.cs:line 16777215  
       at Telerik.JustCode.JustCodeApplication.PerformCommand(String commandName) in c:\B\Manticore\Production\Sources\source\JustCode.Application\JustCodeApplication.cs:line 220  
       at Telerik.JustCode.AddIn.JustCodeAddInBase.Exec(String CmdName, vsCommandExecOption ExecuteOption, Object& VariantIn, Object& VariantOut, Boolean& Handled) in c:\B\Manticore\Production\Sources\source\JustCode.AddIn\JustCodeAddinBase.cs:line 151  
     
     

    Thanks!
  15. Dyt Iscus
    Dyt Iscus avatar
    9 posts
    Member since:
    Jul 2005

    Posted 20 Nov 2009 Link to this post

    Sorry i was to quick with my comment...
    But the answers,
    - It's a codebehind of an asp.net file but it also occurs in a web.config and other class files.
    - It happens everytime as soon as i hover or click on an error.

    Can it be that the latest build is slower?
    Gave it just another try for testing config files wich resulted in an other error:

    INFO 2009-11-20 17:53:58.802 : JustCode Version: 2009.3.1120.13
    INFO 2009-11-20 17:53:58.811 : VS Version: 9.0
    INFO 2009-11-20 17:54:05.332 : Solution initialization started.
    INFO 2009-11-20 17:54:05.539 : Started engine service process id 3500
    INFO 2009-11-20 17:54:05.683 : Server (3500): Code analysis process started.
    INFO 2009-11-20 17:54:05.847 : Server (3500): Code analysis service is ready.
    INFO 2009-11-20 17:54:05.853 : Connection to engine service elapsed: 332
    INFO 2009-11-20 17:54:08.155 : Solution initialization completed.
    INFO 2009-11-20 17:54:09.625 : Registering solution!
    INFO 2009-11-20 17:54:44.599 : Server (3500): Callback channel faulted. Exiting server.


  16. Michael Josiah
    Michael Josiah avatar
    92 posts
    Member since:
    Nov 2007

    Posted 20 Nov 2009 Link to this post

    Hi Ivo

    Your latest build worked great for me. Now I can load up VS2008 without it crashing. Time to play with my new toy me thinks.

    Thanks
  17. Ivo Bratoev
    Admin
    Ivo Bratoev avatar
    107 posts

    Posted 23 Nov 2009 Link to this post

    Hello Michael,
    Good that everything is OK for you now. Don't hesitate to contact us again if you have any problems/comments/suggestions.

    Hello Dyt,
    I haven't been able to reproduce your problem and we have no similar reports yet. I made some research and found that other people experience similar problems using other WPF applications (we use WPF for the JustCode UI):
    http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=321955
    http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=338769
    http://social.msdn.microsoft.com/forums/en-US/wpf/thread/ddc40e5d-f9d6-489f-b6e1-6355ba2f468d/
    http://support.microsoft.com/kb/967634
    http://social.msdn.microsoft.com/forums/en-US/wpf/thread/446f5f1c-4a0b-4479-b4ac-605d3c96d90b

    To sum up the information, you can try the following workarounds to resolve this issue:
    1. Verify that you have .NET 3.5 Service Pack 1 installed.
    2. Ensure you have latest drivers for your video card.
    3. Try running the DirectX WebInstaller.
    4. If you use custom DPI, try switching back to the default.

    Please check if any of these fixes your problem and contact me back.
    It seems the problem is in the framework itself and hopefully it will be fixed soon by Microsoft. Though, I will continue researching the issue and see if we can fix it in our code.

    Regards,
    Ivo Bratoev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  18. Dyt Iscus
    Dyt Iscus avatar
    9 posts
    Member since:
    Jul 2005

    Posted 27 Nov 2009 Link to this post

    Hi Ivo,

    I tried it all but JustCode won't work.
    Since we work in a vmwarebox 6.5 i suggested my chef to upgrade to vmware 7 because there are several graphical improvements.
    To my surprise JustCode was running stable after upgrading my machine to vmware7. I can't really tell why but I'm a happy coder again;)

    Thanks for the help Ivo.

    Cheers!
  19. Ivo Bratoev
    Admin
    Ivo Bratoev avatar
    107 posts

    Posted 27 Nov 2009 Link to this post

    Glad that everything worked out Dyt. We will test JustCode in vmwarebox 6.5.
    Thanks for the report.

    Kind regards,
    Ivo Bratoev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top
DevCraft banner