cordova 3.6.3 and ios 8

5 posts, 0 answers
  1. Darren
    Darren avatar
    32 posts
    Member since:
    Sep 2013

    Posted 01 Oct 2014 Link to this post

    Hi

    Do you have a time frame for appbuilder to support cordova 3.6.3 and also suppporting ios 8 and what feature will be added - like new ios 8 icon sizes etc

    Thanks Darren
  2. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 02 Oct 2014 Link to this post

    Hi Darren,

    We are currently working on the iOS 8 support, even though you should be able to deploy on such device already. There are some lapses like the new icon sizes that we will have to add and if you have anything in mind I will be glad if you share it with us. We have targeted the iOS changes for the upcoming release at the end of the month, but you never know. Sometimes unexpected changes arise. Here is a link to our roadmap notes where you can find more information.

    Regarding the Cordova 3.6.3, I would like to ask you if there is anything important in that version which you would like to see. We strive to keep Cordova up to date, but most of the time we add support for a stable versions like 3.5 / 3.6 etc and I cannot specify a time frame.

    Regards,
    Zdravko
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  3. Darren
    Darren avatar
    32 posts
    Member since:
    Sep 2013

    Posted 06 Oct 2014 in reply to Zdravko Link to this post

    Hi Zdravko

    Thanks for your response.

    No there is nothing in particular that I need in Cordova 3.6.3. Just reading the release notes there appears to be quite a lot of fix/features/enhancements.

    Thanks
    Darren
  4. JohnVS
    JohnVS avatar
    76 posts
    Member since:
    Apr 2013

    Posted 03 Dec 2014 in reply to Zdravko Link to this post

    Regarding Cordova 3.6 being important, one very important thing that is causing us headaches is that Cordova 3.5 doesn't seem to support Geolocation on iOS 8. Geolocation works in our app on Android and iOS 7, but our users on iOS 8 don't get the prompt to give permission for Geolocation. Is there any way to fix this, even temporarily, until 3.6 is released?
  5. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3298 posts

    Posted 08 Dec 2014 Link to this post

    Hi John,

    Are your users running the app directly on an iOS8 device? I am asking as there is a known issue in the AppBuilder companion app, not allowing it to utilize the geolocation services on iOS8 devices. If, you are not using the companion app and your app is still not asking users for location permissions, then as a workaround you can try explicitly setting the NSLocationAlwaysUsageDescription key in the Info.plist of your app.

    In the meantime, we will do our best to implement Cordova 3.6+ support in AppBuilder by the end of the year and iOS8 API support in the beginning of next year.

    Regards,
    Tina Stancheva
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top