Continual high CPU utilisation with VS extensions

2 posts, 0 answers
  1. Richard
    Richard avatar
    18 posts
    Member since:
    Jun 2014

    Posted 12 Feb Link to this post

    I run VS2015 and Kendo ASP.NET MVC on a Parallels VM (2 CPUs).  I have found that my build times had increased from 1 minute to around 10 minutes and the CPU was running with 50% utilisation (i'm guessing one core at 100%) continuously even just in the IDE with no activity.

    Disabling the VS extensions seems to solve the issue (but is not obviously what I'd like to do).

    Is this behaviour to be expected?



  2. Ventsi
    Ventsi avatar
    46 posts

    Posted 16 Feb Link to this post

    Hi Richard,

    Thank you for contacting us.

    This behavior is not expected. The Visual Studio extensions are designed to be as lightweight as possible. They do not consume system resources when they are not being used. In addition, the extensions do not interfere in the build process of the studio.

    I would suggest to reinstall the UI for ASP.NET MVC extensions and check if the issue still exists. Another thing you can do is to install another extensions to check if the CPU consumption is still high.

    Please do not hesitate to contact us in case further questions arise.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for ASP.NET AJAX banner
Back to Top