Captcha on SharePoint 2013 Unauthorized

2 posts, 0 answers
  1. Sebastian
    Sebastian avatar
    2 posts
    Member since:
    Oct 2014

    Posted 14 Sep Link to this post

    Hi,

     

    We have a problem with captcha in Production environment. In development and testing is working fine.

    In production we have a webapp in port 1800 for administration and a extended site in port 80 for anon users, when you access via 80 the captcha does not display the image and is returning error 401. http://www.molymet.cl/es/Paginas/Contact-Us.aspx

    I'm attaching both webconfig.

     

  2. Marin Bratanov
    Admin
    Marin Bratanov avatar
    3599 posts

    Posted 19 Sep Link to this post

    Hi Sebastian,

    The captcha seems to work fine for me (I am attaching a screenshot with the expected request which works fine).

    What I can suggest at this point is the following:

    • if you are using a web farm environment, review the following article to see how to set up the handlers and the captcha itself: http://docs.telerik.com/devtools/aspnet-ajax/controls/captcha/troubleshooting/using-webfarm-or-webgarden-environment.
    • since I see a mobile view in the screenshot (the web config screenshots seem to not open for me) I suggest you use the HttpHandlerUrl property of the control to configure it to request Telerik.Web.UI.WebResource.axd in a folder that is accessible, for example _layouts (note that you should use a folder that provides access, it is not necessarily the _layouts folder): 
      <telerik:RadCaptcha ID="RadCaptcha1" Runat="server" ForeColor="Red"
       ErrorMessage="You have entered an invalid code." HttpHandlerUrl="~/_layouts/Telerik.Web.UI.WebResource.axd">
      </telerik:RadCaptcha>

      because when a RadCaptcha control is placed in a SharePoint site with anonymous access enabled (http://blog.cloudshare.com/blog/2012/10/15/how-to-enable-anonymous-access-to-a-sharepoint-2013-site) and viewed from a mobile browser, the HttpHandler that serves the captcha image should be requested in a folder that can be accessed by anonymous users. If the HttpHandler is not configured, the image will not appear.
    • try adding a <location> element in the web.config to allow access to the handler for anonymous users

     

    Regards,

    Marin Bratanov
    Telerik by Progress
    Do you need help with upgrading your ASP.NET AJAX, WPF or WinForms projects? Check the Telerik API Analyzer and share your thoughts.
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top