Build problems (spinner never goes away)

2 posts, 0 answers
  1. Adam
    Adam avatar
    8 posts
    Member since:
    Oct 2013

    Posted 16 Oct 2013 Link to this post

    At some point in the past few days, my builds stopped fully completing.

    The .apk or .ipa files are created and downloaded but the spinner just keeps spinning and the QR code is not displayed.  To get another build to occur I have to restart Visual Studio.

    Here is my latest output:
    Building package: [C:\dev\GitHub\QuickHelp\Application\obj\Debug\Quick Help.zip]
    Sending build request for project Quick Help with parameters ProjectTypeGuids={070BCB52-5A75-4F8C-A973-144AF0EAFCC9}
    AppIdentifier=com.iboard.quickhelp
    ProjectName=Quick Help
    ProjectGuid=a60f2a7c-1bbf-4330-888d-a2dd8ed5d2ed
    Platform=iOS
    MobileProvisionIdentifier=05cc06aa-5b9b-49dc-a585-dec66b30efde
    iOSCodesigningIdentity=iOS Distribution iBoard Inc
    Configuration=Debug
    IsRunnable=true
    FrameworkVersion=3.0.0
    CorePlugins=org.apache.cordova.core.device;org.apache.cordova.core.AudioHandler;org.apache.cordova.core.battery-status;org.apache.cordova.core.camera;org.apache.cordova.core.console;org.apache.cordova.core.contacts;org.apache.cordova.core.device;org.apache.cordova.core.device-motion;org.apache.cordova.core.device-orientation;org.apache.cordova.core.dialogs;org.apache.cordova.core.file;org.apache.cordova.core.file-transfer;org.apache.cordova.core.geolocation;org.apache.cordova.core.globalization;org.apache.cordova.core.inappbrowser;org.apache.cordova.core.media-capture;org.apache.cordova.core.network-information;org.apache.cordova.core.splashscreen;org.apache.cordova.core.vibration
    AndroidPermissions=android.permission.VIBRATE;android.permission.ACCESS_COARSE_LOCATION;android.permission.ACCESS_FINE_LOCATION;android.permission.ACCESS_LOCATION_EXTRA_COMMANDS;android.permission.READ_PHONE_STATE;android.permission.INTERNET;android.permission.READ_CONTACTS;android.permission.ACCESS_NETWORK_STATE
    DeviceOrientations=Portrait
    iOSStatusBarStyle=Default
    AndroidHardwareAcceleration=false
    LiveSyncToken=8PskIUyfg9uTuZuRFWhmv9kxphEDAbfOut/muTDZxf8s5mvsJAFWN58Myc8tY9kyN86iPy92NxePucaNnLBdy/EbpRYsiwfeFG5dxAurBbc=.
    Package is successfully built. Result is at bin\iOS\Debug\app.ipa.
    Downloading from Private_Build_Folder\Quick Help_-313651243\Quick Help\bin\iOS\Debug\app.ipa to C:\dev\GitHub\QuickHelp\Application\bin\Debug\iOS\app.ipa.
    File downloaded successfully at C:\dev\GitHub\QuickHelp\Application\bin\Debug\iOS\app.ipa.
  2. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 21 Oct 2013 Link to this post

    Hello Adam,

    This is a known problem in the current version of the Icenium extension for Visual Studio and it only occurs in very rare occassions. We would address this problem for the official release of the extension in the upcoming Icenium version. For the time being (as kind of a workaround), please create a new Icenium project in Visual Studio and then go back to your actual project and build it - the build should complete.

    Please excuse us for the temporary inconvenience.

    Regards,
    Steve
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top