Association Editor greyed out?

2 posts, 0 answers
  1. Leon Condon
    Leon Condon avatar
    3 posts
    Member since:
    Sep 2008

    Posted 12 Jun 2011 Link to this post

    Hi All,

    I am using the forward mapping tool in VS (latest ORM release - 2011.1.411.2).

    I can drag on classes and create properties and designate one of those properties as the primary key.

    If I click on association and then click a class and then another class I get the association mapping window appear, but all the options are greyed out except selecting the source and the target.  If I click on the relational view I can only tick the option for a join table and the only option is (Default).

    I can't edit any of the other bits.

    Please see attached screen shot for an example.

    Its annoying since I can't designate my primary and foreign keys.

    Is it something I am doing wrong with my mapping or class creation?

    Thanks.
  2. Zoran
    Admin
    Zoran avatar
    534 posts

    Posted 14 Jun 2011 Link to this post

    Hi Leon Condon,

     That is unfortunately by design at the moment, as you have to have your classes mapped e.g. there should be columns mapped to each property in your classes. We understand that this is not a good user experience and we are currently working on a major re-design of our associations which will allow user to create associations exactly in the way that you want at the moment. However that functionality is scheduled for the first Service Pack of the Q2 release.

    At the moment you can only workaround the behavior by default mapping your classes to tables and your properties to columns. You can do that by selecting an entity on the design surface and checking the  'Use Default Mapping' checkbox in the mapping details editor.

    Kind regards,
    Zoran
    the Telerik team
    Q1’11 SP1 of Telerik OpenAccess is available for download; also available is the Q2'11 Roadmap for Telerik OpenAccess ORM.
  3. DevCraft banner
Back to Top