Assigned To

4 posts, 1 answers
  1. Hector
    Hector avatar
    13 posts
    Member since:
    Apr 2009

    Posted 09 Feb 2011 Link to this post

    When syncing between TFS and teampulse, I was getting errors when trying to update the Assigned To field. TFS did the like the value because it was not matching the availble user accounts. Is this by design with Team Pulse ? The way I fixed it was to Modify the first and last name in the user management to match TFS.
  2. Answer
    David Harris
    Admin
    David Harris avatar
    1 posts

    Posted 09 Feb 2011 Link to this post

    Hi Hector,

    Alternatively to modifying the TeamPulse User Management names you can edit the sync mapping information to perform value mappings between TeamPulse user names and TFS user names. To do this, on the Sync Info screen you would expand the Remote Server Configuration section (see attached screenshot 'expand server configuration.png') and then open the sync mappings xml (see attached screenshot 'edit sync mappings.png').

    Looking through the xml, underneath the <EntityMappings> tags is an empty <ValueMappings /> tag which can be filled out to map TP user names to TFS user names (this will be almost at the bottom of the document). Attached is an example of how that section might look when completed (see 'valuemappings.png').

    Then you need to add an association to the AssignedTo field on each relevant entity (Story, Task) to use that value mapping data when syncing, which might look like the highlighted attribute areas in the attached screenshot 'field value mapping assignment.png' (look to the far right on the screenshot).

    If you decide to go this route rather than manually matching the names between the two systems, please let us know if you have any issues and we will attempt to provide further guidance.

    All the best,
    David Harris
    the Telerik team
  3. stephane
    stephane avatar
    6 posts
    Member since:
    Nov 2010

    Posted 14 Feb 2011 Link to this post

    Thanks, that was useful, I was getting the same problem, that I first solved the same way : changing the name of the user.

    Sidenote : I was looking for an "upvote button" on your answer. How do you track the number people who had this issue if they don't post a "thank you" answer like I do now.
    I can see that an upvote button would let you know if many people got into the same situation as the original poster, which would point you to a potential usability problem of the product. Just my 2 cents.
  4. Velin
    Admin
    Velin avatar
    391 posts

    Posted 14 Feb 2011 Link to this post

    Hi Stephane,

    Thanks for your feedback.

    Currently we do not have an "upvote button" and we wouldn't have any clue that you've had this problem if you didn't contact us.

    We have plans for the near future to add TeamPulse to our Public Issue Tracking System where you could report and vote for any TP problem you have.

    Best wishes,
    Velin
    the Telerik team
    Do you want to explore the latest TeamPulse features? Now it’s easy, try the online Demo and let us know what you think about the product.
Back to Top