ASP Net Core

34 posts, 0 answers
  1. Jan Olsmar
    Jan Olsmar avatar
    35 posts
    Member since:
    Mar 2006

    Posted 09 Jun Link to this post

    When do you have a working release?

    The nuget package 2016.2.607 does not install.

    When do we have a version for payed customer without demo message.

    When will the documentation for RC2 be updated?

    I know it is a RC but as you advertise and blog about it as if it works I am a little suprised that the quality is so bad.

  2. Landry
    Landry avatar
    33 posts
    Member since:
    Oct 2015

    Posted 10 Jun Link to this post

    This is true that the latest version (nuget package 2016.2.607) is not a fully RC2 migrated version as it still references packages coming from RC1 that are not on official nuget anymore.

     

    This can't be use to upgrade our projects to RC2 as it should.

     

    Is there any plans for releasing a new package correcting these issues?

  3. UI for ASP.NET MVC is VS 2017 Ready
  4. Landry
    Landry avatar
    33 posts
    Member since:
    Oct 2015

    Posted 10 Jun in reply to Landry Link to this post

    A lot of people are experiencing the same problem in this thread:

    Thread

  5. cj
    cj avatar
    3 posts
    Member since:
    Jul 2012

    Posted 11 Jun Link to this post

    Is there an official response to this? One way or another on a fix or what the take is from teleriks standpoint?
  6. Brian
    Brian avatar
    7 posts
    Member since:
    Nov 2015

    Posted 11 Jun Link to this post

    Oo was just about to upgrade to rc2 and rc2 telerik kendo but glad i didnt now.

     

    Hope to see a response from telerik on the matter soon.

     

     

  7. Vasil
    Admin
    Vasil avatar
    1547 posts

    Posted 13 Jun Link to this post

    Hi,

    As posted by Landry you may follow the github issue for more information.

    To use the RC2 you also need Visual Studio 2015 with SP2 installed.
    Install the 4.5.2 framework.
    https://www.microsoft.com/en-us/download/details.aspx?id=42642
    Install latest .net SDK
    https://www.microsoft.com/net/core#windows

    Then you can run "dotnet restore" to obtain the new rc2 packages.

    We also have plans to migrate the folowing project to RC2 this week:
    https://github.com/telerik/ui-for-aspnet-mvc-6-demos
    So once migrated you may want to use it as working example.

    Regards,
    Vasil
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  8. Jan Olsmar
    Jan Olsmar avatar
    35 posts
    Member since:
    Mar 2006

    Posted 13 Jun in reply to Vasil Link to this post

    Please answer my questions.
  9. cj
    cj avatar
    3 posts
    Member since:
    Jul 2012

    Posted 13 Jun in reply to Vasil Link to this post

    When Installing kendo.mvc and running dotnet restore results in the error:

        Unable to resolve 'Microsoft.Dnx.Compilation.CSharp.Abstractions (>= 1.0.0-rc2-20221)' for '.NETCoreApp,Version=v1.0'.
        Unable to resolve 'Microsoft.Extensions.CompilationAbstractions (>= 1.0.0-rc2-20221)' for '.NETCoreApp,Version=v1.0'.

  10. Per
    Per avatar
    116 posts
    Member since:
    Jan 2008

    Posted 14 Jun Link to this post

    Comon Telerik, this is a blocking error !

    Please give us some information about when the dependency errors are going to be fixed.

    Telerik MVC should be targeting netstandard1.x instead of netcoreapp1.0

  11. Vasil
    Admin
    Vasil avatar
    1547 posts

    Posted 14 Jun Link to this post

    Hello,

    For your current projects, you can install the packages manually as discussed already here:
    https://github.com/telerik/kendo-ui-core/issues/1682
    Install packages (first select new Package source) Install-Package Microsoft.Extensions.CompilationAbstractions -version 1.0.0-rc2-20221 Install-Package Microsoft.Dnx.Compilation.CSharp.Abstractions -Version 1.0.0-rc2-20221

    We will correct the references for our next release.

    @Jan, You can find the documentation here: http://docs.telerik.com/kendo-ui/aspnet-mvc/mvc-6/introduction
    We are actively working the suite and the documentation as well to be ready for the official Core release. All the feedback is appreciated. We can not give time-frame for each particular issue, but we will do our best to fix everything that we are aware of.

    Regards,
    Vasil
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  12. Per
    Per avatar
    116 posts
    Member since:
    Jan 2008

    Posted 14 Jun Link to this post

    Thanks for the update!

    Can you give us a timeframe for when the next release is coming?

    Right now we cannot use build systems like VSTS because they cannot resolve the packages and this is blocking CI :(

    Regards

    Per

     

     

  13. Jan Olsmar
    Jan Olsmar avatar
    35 posts
    Member since:
    Mar 2006

    Posted 14 Jun in reply to Vasil Link to this post

    Hope next release will be better then. I don't like to spend time on low quality Products. I expect a product to work when you blog about it. I expect good information if it by accident don't work. I expect more than this..

     

  14. Brian
    Brian avatar
    7 posts
    Member since:
    Nov 2015

    Posted 14 Jun in reply to Jan Olsmar Link to this post

    New issue raised for this here

     

    https://github.com/telerik/kendo-ui-core/issues/1783

     

     

  15. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 14 Jun Link to this post

    Hi guys,

    I just answered this issue: https://github.com/telerik/kendo-ui-core/issues/1783.

    We do understand the inconvenience that the namespeace issue is causing and we are currently working with priority on it to solve it. Once this is done, we will release a new build.


    Best regards,
    Rumen
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  16. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 15 Jun Link to this post

    Hi guys,

    We will be grateful, if someone send us a sample working project, which demonstrates the issue with the Microsoft.Extensions.CompilationAbstractions and Microsoft.Dnx.Compilation.CSharp.Abstractions namesapces?

    It will help us to test the hotfix before providing it publicly. Thank you in advance!

     
    Best regards,
    Rumen
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  17. Jan Olsmar
    Jan Olsmar avatar
    35 posts
    Member since:
    Mar 2006

    Posted 15 Jun in reply to Rumen Link to this post

    How about open Visual Studio 2015. File new Project. Asp net Core app. Test the two core apps there.

    Add --- "Kendo.Mvc": "2016.2.607", to project.json

    Read the log.

    Then you have a working Project which demonstrate the issue.

  18. Jan Olsmar
    Jan Olsmar avatar
    35 posts
    Member since:
    Mar 2006

    Posted 15 Jun in reply to Rumen Link to this post

    But the issue seems to be fixed now.
  19. Per
    Per avatar
    116 posts
    Member since:
    Jan 2008

    Posted 15 Jun in reply to Rumen Link to this post

    This is how you reproduce the problem:
    1) Remove any custom nuget feed you added to Visual Studio 2015. You should only have the default one listed.
    2) Clear your nuget cache by "del %LOCALAPPDATA%\NuGet\Cache*.nupkg /q"
    3) Create a new ASP.Net Core Rc2 Web Project
    4) Add Kendo MVC to dependencies in Project.json
    Regards
    Per
  20. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 15 Jun Link to this post

    I'm happy to hear that you are unable to reproduce the issue.

    If someone else, however, still experiences it, it would be of great help for us, if he/she provide a sample working project that demonstrates it.

    Regards,
    Rumen
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  21. Jan Olsmar
    Jan Olsmar avatar
    35 posts
    Member since:
    Mar 2006

    Posted 15 Jun in reply to Rumen Link to this post

    I reproduced it three times 35 minutes ago but now it works so I asume you have added a new package to nuget.

    Now I hope to get an answer regarding the demo message asked 5 Days ago.

  22. Per
    Per avatar
    116 posts
    Member since:
    Jan 2008

    Posted 15 Jun in reply to Rumen Link to this post

    Telerik, please stop this nonsens! Nothing is resolved!

    Follow my instructions above and you will reproduce the problem, this is not a hard thing to do.

    You probobly have the right nuget packages already cached localy and that's why you can't reproduce it. Clear the cache!

    and even then, you can just expand the Kendo package and see that the dependecies are all wrong.

    The only post we need right now is a time frame for when this problem is going to get resolved. Unless you have tons and tons of code depending on thoose two packages, this should be easily fixed.

     

  23. Per
    Per avatar
    116 posts
    Member since:
    Jan 2008

    Posted 15 Jun Link to this post

    I'm gonna make it even easier.

    Go to: https://www.nuget.org/packages/Kendo.Mvc/

    Look at the Dependencies:

    All dependencys with version number: 1.0.0-rc2-20221 are from the Asp.Net Core DEV branch !!!

    Theese should not be here. They should all end with 1.0.0-rc2-final.

    A new package needs to be deployed to fix this problem.

  24. Landry
    Landry avatar
    33 posts
    Member since:
    Oct 2015

    Posted 15 Jun Link to this post

    @Per is right.

     

    Nothing is fixed for now. The problem still occurs.

     

    And yes the dependencies for the nuget package are still wrong and use the wrong nuget feed...

  25. Jan Olsmar
    Jan Olsmar avatar
    35 posts
    Member since:
    Mar 2006

    Posted 15 Jun in reply to Per Link to this post

    Per is right, If I remove the cach I am back with errors.

    So I asume I got the old in the cach between my tests.

  26. Jan Olsmar
    Jan Olsmar avatar
    35 posts
    Member since:
    Mar 2006

    Posted 15 Jun in reply to Per Link to this post

    Per is right, If I remove the cach I am back with errors.

    So I asume I got the old in the cach between my tests.

  27. Landry
    Landry avatar
    33 posts
    Member since:
    Oct 2015

    Posted 15 Jun Link to this post

    Here is a sample solution that demonstrate the problem. (It is just a defaut application generated with Visual Studio template + a reference to Kendo.Mvc nuget package)

     

    If you remove the reference to the Kendo.Mvc nuget package, everything works fine.

    With it, nothing works.

  28. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 15 Jun Link to this post

    **Update** Thank you all for the test project and all the guidance on how to reproduce the issue! This is really appreciated.

    We do know that the problem is not yet fixed, but we are on the right track and hope to release a fix soon.

    Please bear with us.

    Regards,
    Rumen
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  29. Jan Olsmar
    Jan Olsmar avatar
    35 posts
    Member since:
    Mar 2006

    Posted 16 Jun Link to this post

    There is a fix for this now.

    Look in this post

    https://github.com/telerik/kendo-ui-core/issues/1783

    I asume Telerik will post a post it here this or next week.

     

    Now I hope to get an answer regarding the demo message asked 6 Days ago.

  30. Rumen
    Admin
    Rumen avatar
    12849 posts

    Posted 17 Jun Link to this post

    Indeed, the issue #1783 has been resolved!

    @Jan, what do you call a "demo message"? Do you get a trial error? 

    Can you send the message text or a screenshot of it? Thank you!


    Regards,
    Rumen
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  31. Jan Olsmar
    Jan Olsmar avatar
    35 posts
    Member since:
    Mar 2006

    Posted 17 Jun in reply to Rumen Link to this post

    If you read the Telerek release notes for the release you will find

    "All components
    NEW
    Group layers by interaction state in theme PSDs
    Add Trial message that appears randomly for each Control "

    http://www.telerik.com/support/whats-new/aspnet-mvc/release-history/ui-for-asp-net-mvc-r2-2016-sp1

    Its a good thing to read the release notes.

     

Back to Top
UI for ASP.NET MVC is VS 2017 Ready