Appbuilder hanging

4 posts, 0 answers
  1. ofer
    ofer avatar
    6 posts
    Member since:
    May 2014

    Posted 27 Jul 2015 Link to this post

    Our version of Appbuilder is hanging on the windows client. When switching states within our ionic app, the simulator makes a request to "platform.telerik.com" and times out after ~1 minute.

    This is present using the CLI on Windows and the Visual Studio Client.

     It is not present in the OSX CLI using Sublime.

     Attached is a ping to the requested Host URL and also a Fiddler screenshot of the request statistics.

     

  2. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 30 Jul 2015 Link to this post

    Hi ofer,

    Thank you for contacting us.

    I believe you might have come across a caching issue in the AppBuilder Simulator for Windows. In order to check if this is so, please follow the next steps:
    1. Close any opened AppBuilder and VS instances on your PC.
    2. In File Explorer, navigate to the %localappdata%\Telerik\BlackDragon\ folder.
    3. There, delete the whole Cache folder.

    After that, start the preferred AppBuilder client again and see if the faulty behavior is still present. I hope this helps, please let me know of the results and if needed, I will assist you further.


    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  3. ofer
    ofer avatar
    6 posts
    Member since:
    May 2014

    Posted 05 Aug 2015 in reply to Kaloyan Link to this post

    Unfortunately, that did not help. We've isolated the issue to the following:

    - Visual Studio Community '13

    - Upon changing state in an ionic app, a new state with images hangs for roughly 45 seconds each state change. The requests through fiddler show the images were all requested and downloaded in 500ms or less. Can provide Fiddler screenshots if helpful.

    As mentioned before, this is not present on OSX using sublime / Appbuilder CLI. 

     We also have one other questions / concern as well:
    - We're unable to use OSX Sublime / Appbuilder because the simulator does not respond to media queries as the Windows simulator does. 

  4. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 10 Aug 2015 Link to this post

    Hello ofer,

    Thank you for getting back to us. In order to investigate the issue further, we will require the Fiddler log as well as an AppBuilder project that clearly reproduces the faulty behavior in the simulator. Please, share those with us in a private support ticket to prevent any sensitive data leak.

    As for media queries, the Windows Simulator support them, but as replied here there are still issues we need to address. The AppBuilder Simulator on Mac however, does not support media queries at all.

    Regards,
    Kaloyan
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top