AppBuilder crashing

4 posts, 1 answers
  1. Scott
    Scott avatar
    29 posts
    Member since:
    Nov 2013

    Posted 06 Jan 2015 Link to this post

    I'm having a problem with AppBuilder, as soon as I launch it it crashes.  When I look in the logs I see the following stack trace.

    [2015-01-06 10:15:10.022] Log (Info,None): Version 2014.2.731.4. Deployment location https://app.icenium.com.
    [2015-01-06 10:15:10.481] Log (Exception,High): System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
       at System.Reactive.Concurrency.TaskPoolScheduler.<>c__DisplayClass2`1.<>c__DisplayClass4.<Schedule>b__1()
       at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
       at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
       at System.Threading.ThreadHelper.ThreadStart()
    [2015-01-06 10:15:10.897] Log (Exception,High): System.TypeLoadException: Could not load type 'Telerik.BlackDragon.Client.ComponentModel.IFeatureMetadata' from assembly 'Telerik.BlackDragon.Client.Core, Version=2014.2.731.4, Culture=neutral, PublicKeyToken=28c6af4ce7dade13'.

  2. Answer
    Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 09 Jan 2015 Link to this post

    Hi Scott,

    Thanks for the provided stack trace.
    The first thing I noticed is a bit old version you are using. The current one is Version 2014.3.1218.1 so I guess this might be the cause for your issue.
    That is why I would ask you to uninstall your AppBuilder from Windows control panel. Then use this link to download AppBuilder (I suppose you are using Windows client) and install it.

    If this does not help please send us the latest log from  %localappdata%\Telerik\BlackDragon\Logs folder produced using our latest client version in a private support ticket.

    I look forward to your reply.

    Regards,
    Zdravko
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
  3. Scott
    Scott avatar
    29 posts
    Member since:
    Nov 2013

    Posted 09 Jan 2015 in reply to Zdravko Link to this post

    Okay uninstalling and re-installing does the trick.  I was trying to re-install a newer version over the old and that didn't seem to work.
  4. Zdravko
    Admin
    Zdravko avatar
    657 posts

    Posted 14 Jan 2015 Link to this post

    Hi Scott,

    Usually our client should get automatically updated when started and a newer version is available.
    The most important is that everything is back to normal and you can continue your development.

    If you have any other issues do not hesitate to contact us.

    Regards,
    Zdravko
    Telerik
     

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

     
Back to Top