Appbuider in-browser crash

3 posts, 0 answers
  1. Overall
    Overall avatar
    5 posts
    Member since:
    Jan 2016

    Posted 27 Oct Link to this post

    Hello, since last week I am experiencing problems when trying to enter the "AppBuilder". AppBuilder seems to begin (I can see my project files on the screen) but never finishes loading, reaches up to 90% and from there hangs. The browser memory consumption soars 100% (RAM and SWAP), mostly ends up closing the browser and in the worst case hanging around the pc.
    The problem comes in Chrome (54.0.2840.71), Chromium (53.0.2785.143), Firefox (49.0) and Vivaldi browser.
    I'm using GNU / Linux Ubuntu 16.04 (kernel 4.4.0-46). The notebook is a Toshiba i5 with 4GB of RAM and 4GB of swap.

    I have also tested on a macbook on Chrome and Chrome Canary and the same applies. In the mac, the AppBuilder Universal client works OK.
    i see through development tools one warning and one error before hangs:

    Warn: Confict detected, comand 'editor.action.format' cannot be triggered by ctrl+shift+i due to editor.emmet.action.update_image_size.(loader-monaco.js:34)
    Err: Post https://platform.telerik.com/screenbuilder/api/apps/extensibility/stats/...... 400(bad request). (bootstrap.js:54)

    In appbuilder the last message i see is: 1/1 TypeScript Service: Initializing project files 90%

    Until last week this happened sporadically, but a few days ago is impossible to use.

    Any help would be appreciated

  2. Preslav
    Admin
    Preslav avatar
    49 posts

    Posted 27 Oct Link to this post

    Hello Alejandro,

    Thank you for reporting this faulty behavior.

    There is a known issue similar to the problem you described, which affects the Telerik Platform In-Browser client. We are doing our best to fix the issue as soon as possible.

    Until the fix is released, could you please try the following workaround:
    1. Clear the browser cache and Telerik Platform cookies.
    2. Disable the Offline mode by following these steps:
      • Log in the Telerik Platform In-Browser client.
      • Open an application that still loads or create a new one.
      • Open the Code tab.
      • Click on the gear icon (in the top-right corner) and click Options.
      • Open the Code Editor tab.
      • Uncheck the Enable Offline Mode option.

    If this does not help, I'll be happy to continue my investigation but for that purpose, I'll need an HTTP/HTTPS captured traffic with Fiddler of the whole loading process. You can make a capture by following the approach outlined in How To Capture Fiddler Trace article. I'd recommend that you open a support ticket, which is private and comes with a guaranteed response time, and share the needed information there.

    Regards,
    Preslav
    Telerik by Progress 

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

  3. Overall
    Overall avatar
    5 posts
    Member since:
    Jan 2016

    Posted 27 Oct in reply to Preslav Link to this post

    Thanks for the awnser Preslav!.

    So, i did this: disable offline mode in a new project. I tried to enter to the other project but hangs again. Then, clear the cache and cookies and now its working.

    If this happen again, will send you the Fiddler capture.

     

    Regards,

Back to Top