Android APK publish gives error: You don't have a certificate suitable for Google Play

9 posts, 0 answers
  1. MoriartyX64
    MoriartyX64 avatar
    19 posts
    Member since:
    Jun 2013

    Posted 19 Aug 2013 Link to this post

    I'm following the instructions for an Android Publish here:
    http://docs.icenium.com/code-signing-your-app/configuring-code-signing-for-android-apps/configuring-code-signing-for-android-apps

    In short, I've:
    1. created the self-signed, cryptographic identity for Google Play! - making sure the expiration date is somewhere in 2034
    2. configured the previously created cryptographic identity as Code Signing Identity in the project properties for Android
    3. On the Publish option I keep getting the error: "You don't have a certificate suitable for Google Play! Create new Self-signed identity or import existing certificate."

    Also, I've made sure the app is built with 'RELEASE' configuration.

    No doubt that I'm missing the obvious here. But what am I doing wrong? Basically, I want to download the APK and upload the result myself. But in the Google Play! Developer Console I also get a related error which, roughly translated, states something like: "You've uploaded an APK that is signed for debug mode."

    Any suggestions as to what I'm doing wrong?

    UPDATE: Instructions are followed exactly like the visual guide that Dhananjay has written here: http://telerikhelper.net/2012/12/24/create-apk-package-for-google-play-using-icenium-graphite/
  2. Deyan Varchev
    Admin
    Deyan Varchev avatar
    150 posts

    Posted 22 Aug 2013 Link to this post

    Hello,

     It looks like you are hitting some strange issue that we've not seen before. Does this happen if you create a brand new project or it happens only for some specific project? If it happens only for some specific project we'll need more information on which project you experience this with.
     
     Thank you for your collaboration in advance and we'll be waiting for your answer.

    Regards,
    Deyan Varchev
    Telerik

    Do you enjoy Icenium? Vote for it as your favorite new product here (use short code H048S).
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  3. MoriartyX64
    MoriartyX64 avatar
    19 posts
    Member since:
    Jun 2013

    Posted 22 Aug 2013 Link to this post

    It happens only on one specific project, on one system. The exact instructions work perfectly on a colleague's system, but somehow not on mine. Ios publication works perfectly, though. I'll be happy to provide more information, so please contact me if you want further details. 
  4. MoriartyX64
    MoriartyX64 avatar
    19 posts
    Member since:
    Jun 2013

    Posted 26 Aug 2013 Link to this post

    Correction - it happens on *all* projects/workspaces on my particular system. Making it impossible for me to publish anything to the Google Play Store. 
  5. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 26 Aug 2013 Link to this post

    Hello MoriartyX64,

    I've checked your certificate and everything seems fine. Can you share what is the account you use to login to Graphite and also attach a screenshot of the certification management dialog and the publish -> select certificate dialogs?

    Regards,
    Steve
    Telerik

    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  6. MoriartyX64
    MoriartyX64 avatar
    19 posts
    Member since:
    Jun 2013

    Posted 27 Aug 2013 Link to this post

    Sure thing. The account used is the same as I'm using to login to this forum. 

    Enclosed are two screenshots with the user options, project properties and the publish screen. 

    Note: the certificate used is also the one used by a colleague developer to publish the initial version. If I generate a self-signed certificate with an expiration date somewhere in 2035 (for example), it still has the same behaviour. 

    UPDATE: This only seems to occur in Graphite. I've just tried with Mist, which seems to work just fine for creating a publishable APK (added screenshot).
  7. Steve
    Admin
    Steve avatar
    10941 posts

    Posted 28 Aug 2013 Link to this post

    Hi,

    We can't reproduce this in our local tests with your certificates, they are both shown in the Publish dialog in Graphite as in the Publish dialog screenshot you've given from Mist. As this works for your colleague on another machine and it also works from your account in Mist, it might be a corrupted Graphite install/update.

    You can try to wipe clean the Graphite installation:

    1. Close all Icenium Graphite instances. Open the Task Manager and make sure that there are no running processes with the name Icenium.Graphite.exe. If there is - kill it.
    2. Uninstall Graphite.
    3. Delete all contents in the %localappdata%\Temp\IceDeviceSimulator folder.
    4. Delete all contents in the  %localappdata%\Telerik\BlackDragon\ folder.
    5. Delete all contents in the  %localappdata%\Apps\2.0 folder.
    6. Re-install Graphite.

    Regards,
    Steve
    Telerik

    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  8. Rohit Yadav
    Rohit Yadav avatar
    1 posts
    Member since:
    Jul 2009

    Posted 30 Oct 2013 Link to this post

    I am running into the same issue. My application is set to release mode and i have have updated the version to 1.1. Yet uploading the apk complains about that its in debug and needs new version number.
    I tried cleaning everything related to graphite and re installing it but that did not fix the problem for me.

    How do i resolve it?

    Thanks

  9. Ivan Ivanov
    Admin
    Ivan Ivanov avatar
    42 posts

    Posted 01 Nov 2013 Link to this post

    Hi Rohit,

    A possible issue that comes to mind is that you might not have changed the version code property for your new app, you can read more about it here. Setting a proper version and version code are required to be able to publish a new version of your app. If you have not modified this property yet, try increasing it by 1 (it should be an integer) and try building and uploading it again.

    If this is not the case, could you please tell us when do you get this message - when you try to build your app or when you try to upload it to Google play. Would it be possible for you to check if this issue is reproducible in Mist?

    Thank you.
    Regards,
    Ivan Ivanov
    Telerik
    You've missed the Icenium Visual Studio Integration keynote? It has been recorded and posted here.
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
Back to Top