XHTML Output for MOSS 2007

4 posts, 0 answers
  1. starke
    starke avatar
    10 posts
    Member since:
    May 2007

    Posted 07 Jun 2007 Link to this post

    Hi,

    I've read in the post (http://www.telerik.com/community/forums/thread/b311D-thhag.aspx) that sharepoint will filter rich text fields automatically, thus even if RadEditor for MOSS output is xhtml compliant, the result saved by sharepoint will not be.

    I'll like to ask if anybody has any solution in overcoming this problem and make the content xhtml compliant when sharepoint displays it.


    Thanks & Regards
    starke
  2. Lini
    Admin
    Lini avatar
    2144 posts

    Posted 08 Jun 2007 Link to this post

    Hello starke,

    The thread you linked to is about the previous version of the MOSS editor (4.0.0). We have made a lot of enhancements in the current release (4.1.0). One of the changes is to try and make the HTML field output valid XHTML. I advise you to install the 4.1.0 build and review the WCM field editor again.

    Greetings,
    Lini
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center

  3. Sam Langdon
    Sam Langdon avatar
    6 posts
    Member since:
    Apr 2006

    Posted 27 Jun 2007 Link to this post

    I'm having the same issue and I'm using 4.1. As starke says though, it's not the editor so much as the way MOSS 2007/WSS renders the HTML. For example, it actually removes the xhtml from this:

    <strong class="ms-rteCustom-ArticleHeadLine">Some nice formatted text<br /><br /><img style="WIDTH: 66px; HEIGHT: 42px" alt="My image" hspace="1" src="http://mywebsite.dev.l360.co.uk/Style%20Library/Images/bl_logo.jpg" vspace="1" border="0" longdesc="My image" /></strong>


    turning it into this:

    <strong class=ms-rteCustom-ArticleHeadLine>Some nice formatted text<br><br><img style="width:66px;height:42px" alt="My image" hspace=1 src="/Style%20Library/Images/bl_logo.jpg" vspace=1 border=0 longdesc="My image"></strong>

    Any ideas? Is there a doctype setting in Sharepoint I'm missing?

    Cheers,
    Sam

  4. Sam Langdon
    Sam Langdon avatar
    6 posts
    Member since:
    Apr 2006

    Posted 27 Jun 2007 Link to this post

    Scrub that - I just found the answer in the aforementioned post (http://www.telerik.com/community/forums/thread/b311D-thhag.aspx) - just need to use a plain text field instead of a rich text field. Nice (but overcomplicated - damn you Sharepoint).
Back to Top