WeekView column headers: culture nl-NL issue

2 posts, 1 answers
  1. Marja
    Marja avatar
    70 posts
    Member since:
    Nov 2013

    Posted 19 Jun 2015 Link to this post

    Hi,

    (using Telerik.Web.UI 2015.1.401.45)

    I have my RadSchedular setup like this:

    <telerik:RadScheduler ID="RadScheduler1" SelectedView="WeekView"
        OnClientDataBound="wsOnSchedulerDataBound" OnClientAppointmentsPopulating="wsOnClientAppointmentsPopulating"
        OnClientNavigationComplete="wsOnClientNavigationComplete" OnClientAppointmentInserting="wsOnClientAppointmentInserting"
        OnClientAppointmentEditing="wsOnClientAppointmentEditing" OnClientAppointmentDeleting="wsOnClientAppointmentDeleting"
        OverflowBehavior="Expand" StartInFullTime="true" StartEditingInAdvancedForm="false"
        AllowDelete="true" AllowEdit="true" AllowInsert="true" EnableRecurrenceSupport="false" AppointmentStyleMode="Default"
        Culture="nl-NL" FirstDayOfWeek="Monday" LastDayOfWeek="Sunday"
        runat="server">
     
        <WebServiceSettings Path="wsPlanningServices.asmx" ResourcePopulationMode="ServerSide" />
        <AdvancedForm Modal="true"></AdvancedForm>
        <AppointmentContextMenuSettings EnableDefault="true" />
        <TimeSlotContextMenuSettings EnableDefault="true" />
        <DayView HeaderDateFormat="dd-MM-yyyy" />
        <WeekView HeaderDateFormat="dd-MM-yyyy" ColumnHeaderDateFormat="ddd d MMM" />
        <MonthView HeaderDateFormat="MMMM yyyy" />
        <AgendaView HeaderDateFormat="dd-MM-yyyy" />
    </telerik:RadScheduler>

    As you can see, I explicitly set the culture to "nl-NL" and also specified a custom WeekView.ColumnHeaderDateFormat.

    Now the column headers should read as eg. "Vr 15 juni", but instead they are rendered as "Fri 19 Jun". 
    So the columns headers are still displayed in English, despite the explicit "nl-NL" culture setting.

    What am I missing here?

  2. Answer
    Plamen
    Admin
    Plamen avatar
    2733 posts

    Posted 24 Jun 2015 Link to this post

    Hello,

    The described behavior is expected since the dates in WeekView are set from the client side. The only way to globalize them by setting the ScriptManager.EnableScriptGlobalization property to true and adding the <globalization culture="auto" /> in the system.web in the web.config as it is described here.

    Hope this will help you solve the issue.


    Regards,
    Plamen
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. UI for ASP.NET Ajax is Ready for VS 2017
Back to Top