WAP Edit & Continue broken with JustMock

8 posts, 0 answers
  1. Chris Owens
    Chris Owens avatar
    12 posts
    Member since:
    May 2004

    Posted 08 Apr 2011 Link to this post

    If I install JustMock I can't use Edit & Continue in a web application project.  Uninstalling it allows the use of Edit & Continue again.  When it's installed, Edit & Continue just pops up either the standard error message about changes not being allowed for various reasons which is the same message you get if you leave the project set for AnyCPU instead of x86.  This is even if everything is set correctly to allow for Edit & Continue.
  2. Ricky
    Admin
    Ricky avatar
    467 posts

    Posted 11 Apr 2011 Link to this post

    Hi Chris,

    Thanks again for sending the issue. However, Please ensure that   "Edit and continue" option  is checked under web tab in project properties page (VS2010).




    Also, I would further recommend you to take a look at this following post:
    http://stackoverflow.com/questions/1088376/how-to-edit-and-continue-in-visual-studio-2008-and-asp-net-mvc

    This actually describes some other options that you might find useful.

    Hope that solves your issue and please write us back if you are still having problems.

    Kind Regards,
    Ricky
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft R3 2016 release webinar banner
  4. Chris Owens
    Chris Owens avatar
    12 posts
    Member since:
    May 2004

    Posted 11 Apr 2011 Link to this post

    As I mentioned, this situation occurs with everything set correctly for Edit & Continue.

    If I uninstall JustMock, Edit & Continue works fine in the same project. Reinstall JustMock and Edit & Continue stops working. 
  5. Ricky
    Admin
    Ricky avatar
    467 posts

    Posted 12 Apr 2011 Link to this post

    Hi Chris,

    Thanks again for the reply. Looking deep into the issue, we found out that since "Edit and continue" option does not work properly when CLR profiler is attached. The only other way in that regard is to disable JustMock addin from VS menu.

    I found an interesting thread that also says the same:
    http://stackoverflow.com/questions/1010213/edit-and-continue-changes-are-not-allowed-when-the-debugger-has-been-attached-t

    Hope this information answers your question.

    Kind Regards,
    Mehfuz
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  6. Bradley Lane
    Bradley Lane avatar
    22 posts
    Member since:
    Aug 2012

    Posted 22 Jul 2012 Link to this post

    I have just uninstalled JustMock due to the same issue!

    Everything works fine after uninstall... have tried this on two machines with same result.

    Note: this issue is not limited to Web Apps.
  7. Ricky
    Admin
    Ricky avatar
    467 posts

    Posted 26 Jul 2012 Link to this post

    Hi Brad,

    Thanks again for pointing the issue.
    We are including this into our backlog and will investigate further on the matter.

    Kind Regards
    Ricky
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  8. Joe
    Joe avatar
    48 posts
    Member since:
    Dec 2007

    Posted 28 Mar 2013 Link to this post

    I'm having the same problem here. Currently I have to disable the JustMock add in and restart VS 2010. It would be helpful if I could disable JustMock temporarily without having to restart VS.
  9. Kaloyan
    Admin
    Kaloyan avatar
    872 posts

    Posted 29 Mar 2013 Link to this post

    Hello Joe,

    For the Enable/Disable Profiler option to work, you will need to uncheck the "Keep test execution engine running between test runs" check box.
    1. On the Tools menu, select Options.
    2. Expand Test Tools and click Test Execution.
    3. Under Performance, clear the check box for Keep test execution engine running between test runs.

    Please, note us if JustMock is still not disabling as expected after having the above steps done.

    I hope this helps.

    Greetings,
    Kaloyan
    the Telerik team
    Share what you think about JustTrace & JustMock with us, so we can become even better! You can use the built-in feedback tool inside JustTrace, our forums, or our JustTrace or JustMock portals.
Back to Top
DevCraft R3 2016 release webinar banner