VS2012 Slow StartUp after updating

2 posts, 0 answers
  1. Stephan Reisinger
    Stephan Reisinger avatar
    24 posts
    Member since:
    Jan 2005

    Posted 29 Jan 2014 Link to this post

    Good afternoon,

    today I updated all available extensions for Telerik Products.

    After updating all the VSExtensions and updating to the latest product releases via the Telerik Control Panel VS2012 startup has slowed down to a crawl.
    Using latest generation Intel SSDs the startup time for VS *before* applying all updates was below the 2 second mark, now after the updates it's close to if not beyond the 2 minute mark.

    I am pretty confident that it is related to Telerik updates since I have not installed anything else between yesterday evening and this morning, and the first startup of VS2012 before the updates was speedy as usual.
    I have ensured that I rebooted a few times, made sure it's not internet related ( monitoring traffic ), that no virus or rootkit etc. was magically installed while the machine was turned off, before I post this.

    I, from a user perspective, point towards the installed updates and do wonder if there is anybody else in the same boat ( which turned from a speedboat to a leisure rowing boat propelled by my wife that is distracted by a women's purse on the shore ).


  2. Dyanko
    Dyanko avatar
    121 posts

    Posted 03 Feb 2014 Link to this post

    Hello Stephan,

    Thank you for writing us.

    I am sorry to hear that such an issue occurred after the upgrade of our products. In order to further investigate the issue we would like to review the Visual Studio activity log. Would you please start your Visual Studio with logging, reproduce the issue and send us the ActivityLog.xml file. The following steps will help you in order to do that:
    1. Start Visual Studio with devenv /log command
    2. Reproduce the problem
    3. Send us the activity log file. By default it should be created in the following location: %APPDATA%\Roaming\Microsoft\VisualStudio\11.0\ActivityLog.xml

    As a workaround of fixing the problem I would recommend to try uninstalling the Telerik products one by one, restart Visual Studio after each product is uninstalled and check if the issue disappears. I would suggest starting with Telerik Data Access and JustCode products. If the issue is no longer reproducible install the already removed products.

    Looking forward to your response.

    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the UI for ASP.NET AJAX, subscribe to the blog feed now.
  3. DevCraft R3 2016 release webinar banner
Back to Top