VS toolbox framework 4.0 items not showing

3 posts, 1 answers
  1. Mathieu
    Mathieu avatar
    2 posts
    Member since:
    Jan 2011

    Posted 03 Mar 2014 Link to this post

    I installed the Q1 2014 package and the components are not showing in the visual studio toolbox under my framework 4.0 projects.

    It is only working by default in framework 4.5 projects.

    In framework 4.0, I can add them manually with the "Choose toolbox elements" option and
    by referencing the 4.0 Telerik UI dll, but they are not classified by
    categories as it is normally by default with telerik.

    I tried resetting
    the toolbox and using the Telerik toolbox configurator but it doesn't work.

    Am I the only one having that problem?

  2. Answer
    Dyanko avatar
    120 posts

    Posted 06 Mar 2014 Link to this post

    Hello Mathieu,

    Thank you for contacting us.

    I would recommend to clear the Toolbox cache which is created by Visual Studio. The following steps will help you to do that:
    1. Close all Visual Studio instances;
    2. Open Windows Explorer and navigate to the directory %localappdata%\Microsoft\VisualStudio\[VS version]
    3. Make sure that the option 'Show hidden files...' is selected in the Windows Explorer options;
    4. Delete all *.tbd files;
    5. Start Visual Studio as Administrator and use the Toolbox Configurator wizard to set the required controls version. Please note that in order to make Telerik controls visible for .NET 4.0 Framework projects you should select .40 distribution from the distribution drop down list.

    You can also get additional information on the Toolbox configuration wizard from the following link: LINK

    Please let us know if we can further assist you.


    DevCraft Q1'14 is here! Join the free online conference to see how this release solves your top-5 .NET challenges. Reserve your seat now!

  3. DevCraft R3 2016 release webinar banner
  4. Mathieu
    Mathieu avatar
    2 posts
    Member since:
    Jan 2011

    Posted 06 Mar 2014 in reply to Dyanko Link to this post

    Thanks, I didn't realize that in the toolbox configurator there was multiple version and that the last digit was the framrwork version.

    Thanks again
Back to Top