Upgrade Wizard detects SL5 as SL4

5 posts, 0 answers
  1. Mark
    Mark avatar
    155 posts
    Member since:
    Oct 2010

    Posted 17 Jul 2013 Link to this post

    The quick and dirty ...

    Had an SL4 solution that we've managed to get to SL5.
    In VS 2010 we "Target SL5", references have been correctly updated.

    he Telerik upgrade wizard for reporting correctly identifies the Project and allows installation of bits version: 7.1.13.612
    The upgrade wizard for RadControls, however, identifies the Project as SL4 and will not allow additional updates.

    Installed version is 2012.2.912.1040 trying to upgrade to 2013.2.611.1050

    Help is appreciated.

    Thanks,
    Mark
  2. Dimitar
    Admin
    Dimitar avatar
    45 posts

    Posted 18 Jul 2013 Link to this post

    Hello Mark,

    Thank you for contacting us.

    You'll have to change the Target Silverlight Version form Silverlight 4 to Silverlight 5 for all your Silverlight projects in the solution in order the Upgrade Wizard treats them as SL5 projects. You can follow these steps to change the targeted framework: Right click on a project -> Select Properties -> Go to the Silverlight tap-> Change the Target Silverlight Version form Silverlight 4 to Silverlight 5.

    Let us know if you need further assistance.

    Regards,
    Dimitar
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. DevCraft banner
  4. Mark
    Mark avatar
    155 posts
    Member since:
    Oct 2010

    Posted 19 Jul 2013 Link to this post

    Hello Dimitar,

    This is indeed my point, all projects are configured as SL5 / NET 4.0 in VS 2010.

    Mark
  5. Mark
    Mark avatar
    155 posts
    Member since:
    Oct 2010

    Posted 20 Jul 2013 Link to this post

    Although this doesn't identify the cause, the solution that worked was to redownload the package outside of VS 2010, install and then the Telerik Wizard worked as expected.
  6. Dimitar
    Admin
    Dimitar avatar
    45 posts

    Posted 22 Jul 2013 Link to this post

    Hi Mark,

    I'm glad to hear you've resolved the issue.
    Please don't hesitate to contact us if any questions arise.

    Regards,
    Dimitar
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for SILVERLIGHT.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
Back to Top
DevCraft banner