Unknown server tag

5 posts, 0 answers
  1. david
    david avatar
    210 posts
    Member since:
    May 2007

    Posted 28 Apr 2008 Link to this post

    Odd, converting to the rad /ajax Q12008 and replaced the assembly and the prefix on an existing (functional ) toolbar - I get 


    Parser Error Message: Unknown server tag 'telerik:RadToolBar'.

    Source Error:

    Line 24:     <tr align="left" bgcolor="#EFEFEF">
    Line 25:       <td > <i><asp:Label ID="label1" runat="server" Text="Label"></asp:Label></i>
    Line 26: <telerik:RadToolBar runat="server" id="toolbar1" AutoPostback="true" Skin="Office2007" UseFadeEffect="True" >


    <%

    @ Page Language="C#" AutoEventWireup="true" CodeFile="Admin-Registration-Account-Master.aspx.cs" Inherits="_Default" %>

    <%

    @ Register TagPrefix="telerik" Namespace="Telerik.Web.UI" Assembly="Telerik.Web.UI" %>

    <%

    @ Register TagPrefix="edway" TagName="HeadTag" Src="HeadTag.ascx" %>

    <!

    DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

    <

    html xmlns="http://www.w3.org/1999/xhtml" >

    <

    head runat="server"><title>Registration Master</title></head>

    <

    edway:HeadTag runat="server" ID="Headtag"></edway:HeadTag>

    <

    body>

    <

    form id="form1" runat="server">

    <asp:ScriptManager ID="ScriptManager1" runat="server"></asp:ScriptManager>

    <table align="left" class="style1">

    <tr align="left" bgcolor="#EFEFEF">

    <td > <i><asp:Label ID="label1" runat="server" Text="Label"></asp:Label></i>

    <telerik:RadToolBar runat="server" id="toolbar1" AutoPostback="true" Skin="Office2007" UseFadeEffect="True" >

    <items>

    <telerik:RadToolBarButton Width="120px" DisplayType="TextOnly" AccessKey="n" Tooltip="New (Alt+N)" CommandName="New Student" />

    <telerik:RadToolBarButton Width="120px" DisplayType="TextOnly" AccessKey="r" Tooltip="Return (Alt+R)" CommandName="Account Detail" />

    <telerik:RadToolBarButton Width="120px" DisplayType="TextOnly" AccessKey="a" Tooltip="Accounts (Alt+A)" CommandName="Accounts" />

    <telerik:RadToolBarButton Width="120px" DisplayType="TextOnly" AccessKey="s" Tooltip="Students (Alt+S)" CommandName="Students" />

    </items>

    </telerik:RadToolBar >

  2. John Davis
    John Davis avatar
    119 posts
    Member since:
    Apr 2007

    Posted 29 Apr 2008 Link to this post

    I have a similar problem.  In the designer I get:

    Unable to cast object of type 'Telerik.Web.Controls.RadToolbar' to type 'Telerik.Web.Controls.RadToolbar'

    My declaration in aspx:

    <%

    @ Control Language="C#" AutoEventWireup="true" CodeBehind="Report_Graph_ViewControl.ascx.cs" Inherits="BalancedFlow.WebSite3._5.Controls.Reports.Report_Graph_ViewControl" %>

    <%@ Register TagPrefix="rad" Namespace="Telerik.WebControls" Assembly="RadToolbar.NET2" %>

    <%

    @ Register TagPrefix="telerik" Namespace="Telerik.WebControls" Assembly="RadComboBox.Net2" %>

    <%

    @ Register Assembly="RadInput.Net2" Namespace="Telerik.WebControls" TagPrefix="rad" %>

    ........

    <asp:Panel ID="Panel1" runat="server" Height="26px" Width="580px">

    <table cellpadding="0" cellspacing="0" class="style4">

    <tr>

    <td>

    <div>

    <rad:RadToolbar runat="server" ID="Ybasis" Skin="Outlook" UseFadeEffect="True">

    <Items>

    <rad:RadToolbarToggleButton AccessKey="l" Toggled="True" ToolTip="DOS (Alt+L)" ButtonGroup="Basis"

    DisplayType="TextOnly" CommandName="DOS" />

    <rad:RadToolbarToggleButton AccessKey="c" ToolTip="Qty (Alt+C)" ButtonGroup="Basis"

    DisplayType="TextOnly" CommandName="Qty" />

    <rad:RadToolbarToggleButton AccessKey="r" ToolTip="Cost (Alt+R)" ButtonGroup="Basis"

    DisplayType="TextOnly" CommandName="Cost" />

    </Items>

    </rad:RadToolbar>

    </div>

    </td>

    <td>

    <div>

    <rad:RadToolbar runat="server" ID="RadtoolbarCutoff" Skin="Outlook" UseFadeEffect="True">

    <Items>

    <rad:RadToolbarButton Enabled="false" Width="5px" DisplayType="TextOnly" ButtonText=" " CommandName="b1" />

    <rad:RadToolbarTemplateButton AccessKey="s">

    <ButtonTemplate>

    <asp:CheckBox ID="chkCutoff" runat="server" Width="12px" Font-Size="Smaller" />

    </ButtonTemplate>

    </rad:RadToolbarTemplateButton>

    <rad:RadToolbarButton Width="29px" DisplayType="TextOnly" CommandName="Cutoff: " />

    <rad:RadToolbarButton Enabled="false" Width="5px" DisplayType="TextOnly" CommandName=" " />

    <rad:RadToolbarButton ToolTip="minus" ButtonImage="minus.gif" CommandName="minus" />

    <rad:RadToolbarTemplateButton AccessKey="s">

    <ButtonTemplate>

    <rad:RadNumericTextBox Skin="Default" ShowSpinButtons="false" ButtonsPosition="Right"

    Type="Number" MaxLength="9" MinValue="0" MaxValue="99999" Width="50" ID="txtCutoffLow"

    runat="server" NumberFormat-DecimalDigits="0">

    </rad:RadNumericTextBox>

    </ButtonTemplate>

    </rad:RadToolbarTemplateButton>

    <rad:RadToolbarButton Enabled="false" Width="5px" DisplayType="TextOnly" ToolTip=" "

    CommandName=" " />

    <rad:RadToolbarButton ToolTip="plus" ButtonImage="plus.gif" CommandName="plus" />

    <rad:RadToolbarTemplateButton AccessKey="s">

    <ButtonTemplate>

    <rad:RadNumericTextBox Skin="Default" ShowSpinButtons="false" ButtonsPosition="Right"

    Type="Number" MaxLength="9" MinValue="0" MaxValue="99999" Width="50" ID="txtCutoffHigh"

    runat="server">

    </rad:RadNumericTextBox>

    </ButtonTemplate>

    </rad:RadToolbarTemplateButton>

    </Items>

    </rad:RadToolbar>

    </div>

    </td>

    <td>

    &nbsp;

    </td>

    </tr>

    </table>

    </asp:Panel>

  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Helen
    Admin
    Helen avatar
    1052 posts

    Posted 29 Apr 2008 Link to this post


    David, we created a sample project based on your code and it works without problems at our side. Please find the project attached to this forum thread. Does it work at your side?

    John, the error you reported is due to design-time bug in VS. It should disappear if you refresh the page. If this doesn't help, please try to close and open again the site. Other than that RadToolbar should work fine at run-time. Please, let us know if this is the case or not.


    Regards,
    Helen
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  5. david
    david avatar
    210 posts
    Member since:
    May 2007

    Posted 29 Apr 2008 Link to this post

    Right, it turns out I was running an old version of the Telerik.Web.Ui.DLL (3.1425) which I think didnt have ToolBar.

    thanks
  6. John Davis
    John Davis avatar
    119 posts
    Member since:
    Apr 2007

    Posted 29 Apr 2008 Link to this post

    Helen

    Yes this error was gone after re-opening the project.   Thanks.
    (Unable to cast object of type 'Telerik.Web.Controls.RadToolbar' )

    John
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017