Unable to edit content in the RAD EDITOR For SharePoint web part

3 posts, 0 answers
  1. Kiran
    Kiran avatar
    1 posts
    Member since:
    Jun 2012

    Posted 11 Jul 2012 Link to this post

    Hi all
    I have noticed following behavior in our SharePoint pages.
    When RAD editor web part is added to a zone, I am able to edit the content within the control.
    After I save the page, check in and then edit the page, I am unable to edit the content. I must add that this happens only in Internet Explorer. Upon looking into the mark up of the page, I noticed that the nearest <div > is set with unselectable=on


    <div id="ctl00_m_g_de8edd76_8f8a_4459_a956_04989983b73e_ctl00_contentDivclass="reContentArea reContentAreaTogglecontenteditable="truestyle="position: relative; height: 211px;unselectable="on"></div>

    Since the div is unselectable, I am not able to get focus in the content editing area.

    Does anyone know why IE injects unselectable="on" into the content area.
    Thanks in advance

  2. Rumen
    Rumen avatar
    12782 posts

    Posted 16 Jul 2012 Link to this post


    To enable RadEditor's Web Part you should press the Enable Web Part button of the web part itself. For your convenience I have recorded a video demonstrating these steps: http://screencast.com/t/XQAwLT4a.

    Kind regards,
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.

  3. Victor
    Victor avatar
    1 posts
    Member since:
    Aug 2014

    Posted 09 Aug 2014 in reply to Kiran Link to this post

Back to Top