Troubleshooting remote connection issues

8 posts, 0 answers
  1. Mike
    Mike avatar
    5 posts
    Member since:
    Aug 2015

    Posted 19 Aug 2015 Link to this post

    I am having trouble accessing Fiddler on my laptop from other devices. The laptop runs Windows 7 Enterprise, and one device I'm trying to connect with is an iPad using iOS 8.4. When I'm at work, I can easily connect to this laptop. I have "allow remote computers to connect" checked, and I use the default port with the local IP set as the proxy on the iPad. It works well. When I take these two devices home, however, I can't even pull up the Fiddler Echo Service page by going to http://laptop:8888 (ie laptop is 192.168.1.9). I can use a ping app on the iPad, and I get a successful response by pinging this same ip on port 23. I've confirmed that Fiddler is still set to listen on port 8888 and rechecked the local ip of the laptop many times. I've removed proxy settings on the iPad's wifi connection, so it's not trying to connect to the local ip from the office network. The proxy settings on the iPad are blank when trying to reach the Fiddler Echo Service page of the laptop. No settings on the laptop have changed from when it was at work.

     I started thinking maybe there was a router issue, but I can run Fiddler on my desktop and have the iPad connect to it after adjusting the wifi proxy settings, and the laptop also reaches the desktop's fiddler echo page. I have not setup any port forwarding for the deskptop in my router.

     Is anybody able to point me in the right direction to get other devices to connect to Fiddler running on the laptop? I'm completely out of ideas on what could be the problem. The only thing that has changed is the network these are on, and I've tried changing the wifi proxy's settings to the correct, new local ip of the laptop on the home network, and other devices on this network are able to accept traffic through Fiddler.

     Any help is greatly appreciated!

  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 20 Aug 2015 Link to this post

    Hi, Mike--

    On Corporate networks, the typical problem with reaching Fiddler on a different PC (when "Allow remote" is enabled) is that the corporate network has IPSEC configured. For instance, Microsoft's Corporate Network uses IPSEC which means Fiddler must be run on a machine with an IPSEC Boundary Exemption.

    On Home wifi networks, the typical problem with reaching Fiddler on a different PC is that the WiFi has a "Network isolation" feature enabled whereby Wifi devices are blocked from talking directly to one another. To make those work, that option must be disabled in the WiFi router's settings.

    In this case, would I be correct in guessing that your desktop is connected to your router via an Ethernet cable while your laptop is connected to the router via WiFi?

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Mike
    Mike avatar
    5 posts
    Member since:
    Aug 2015

    Posted 20 Aug 2015 in reply to Eric Lawrence Link to this post

    Hello, Eric!

     You are absolutely right - my desktop is connected via cable, and the laptop and iPad are using wifi, and so was an iMac that was also not finding the laptop. It should not be too much trouble to make it work now that you have pointed out the problem.

     Thank you very much for your insight!!

  4. Mike
    Mike avatar
    5 posts
    Member since:
    Aug 2015

    Posted 20 Aug 2015 Link to this post

    I am still having trouble with Fiddler. I have checked into my router's settings and tried many things, such as disabling the IGMP proxy. I currently have the laptop wired into the router, and I'm still unable to remote connect to Fiddler running on it from anything - even another wired computer.

     Other possible avenues to explore would be most greatly appreciated! Thank you again for your time and insights.

  5. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 21 Aug 2015 Link to this post

    Hello, Mike--

    What type of router is it that you have? Is it running the default firmware or something else like DD-WRT?

    If you temporarily disable the Windows Firewall on your laptop, does the traffic get to Fiddler?

    Regards,
    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. Mike
    Mike avatar
    5 posts
    Member since:
    Aug 2015

    Posted 21 Aug 2015 Link to this post

    Eric, you've solved it! Disabling McAfee's firewall allowed remote connections on my home network instantly. I don't have to disable it on the corporate network at work, but for some reason it was causing issues here at home. I hadn't suspected that at all, since I haven't had to change the settings at work. Thank you so much for the help, and for such an incredible tool!
  7. Eric Lawrence
    Admin
    Eric Lawrence avatar
    833 posts

    Posted 24 Aug 2015 Link to this post

    Great, thanks for letting me know!

    Many firewalls, including the default one in Windows, have a concept of "Network Profiles" (e.g. Public, Private, Work) where different restrictions are applied based on how you're connected, whether the Windows Domain Controller is on this network, etc.

    Eric Lawrence
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  8. Mike
    Mike avatar
    5 posts
    Member since:
    Aug 2015

    Posted 24 Aug 2015 Link to this post

    That's precisely what the problem was. Apparently the firewall was set such that, when connected to the corporate network, all local connections are allowed. When not on that, all local connections are rejected.
Back to Top