ToolsproviderID not fully working

6 posts, 0 answers
  1. ManniAT
    ManniAT avatar
    877 posts
    Member since:
    Nov 2003

    Posted 04 Mar 2009 Link to this post

    Hi,

    I have a three RadEditors to edit 3 Fields in a database record.
    My Toolbar is generated from a Tools.xml file.

    Following your tips for better performance I use "ToolProviderID" - and yes I got the same toolbar on all three editors.
    BUT - only the first one (with the ToolsFile=) has content in the "Custom Links" and "Snippets" dropdown.
    The other editors also have the toolar items - but the dropdowns are empty.

    I wanted to check if this is a fault of mine via http://demos.telerik.com/aspnet-ajax/editor/examples/toolprovider/defaultcs.aspx
    BUT - unfortunately on this page both (Links, Snipptes) are empty in every case.

    So I set up a blank solution - with a single page containing only two editors - and it still has empty dropdowns.
    So I guess this is some kind of bug.
    I have the same issue with IE7 and Firefox,

    Regards

    Manfred
  2. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 07 Mar 2009 Link to this post

    Hello Manfred,

    When the ToolProviderID property is set then all collections of RadEditor (including the Custom Links and Snippets collections) are reset. The only way to populate these dropdowns with custom items is to remove the ToolProviderID property. This is how this functionality currently works.

    We agree with you that this is not an expected behavior and I logged your request in our ToDo list for implementation. Unfortunately, I cannot provide an estimate date when it will be implemented since our ToDo list for Q1 2009 is pretty set.

    Kind regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Ozan Akiman
    Ozan Akiman avatar
    5 posts
    Member since:
    Feb 2007

    Posted 25 Dec 2009 Link to this post

    Hi,

    As of Q3 2009 the issue seems to be persisting. Is there any updates on the fix or a suggested workaround?

    Regards,
    Ozan Akiman
  5. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 28 Dec 2009 Link to this post

    Hello Ozan,

    The enhancement of the ToolProviderID feature was postponed because there were features logged with higher priority.

    I logged your requests in our PITS (public issue tracking) system which should become public on Telerik.com soon and you will be able to check its status. Your fellow developers could also vote for this issue and increase its priority.

    Kind regards,
    Rumen
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Contra
    Contra avatar
    10 posts
    Member since:
    Aug 2009

    Posted 13 Apr 2010 Link to this post

    how is this coming along? It baffled my mind when I read that this is not a bug, cause it sure lt sure looked that way.

  7. Rumen
    Admin
    Rumen avatar
    12846 posts

    Posted 14 Apr 2010 Link to this post

    Hi Contra,

    This feature request was implemented and the ToolsproviderID property works as expected in the latest Q1 2010 build of RadControls for ASP.NET AJAX.

    You can check the status of the PITS issue at:

    http://www.telerik.com/support/pits.aspx#/public/aspnet-ajax/430

    Greetings,
    Rumen
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top
UI for ASP.NET Ajax is Ready for VS 2017