Too many Telerik controls causes style loss in IE

2 posts, 1 answers
  1. Mark
    Mark avatar
    79 posts
    Member since:
    Apr 2007

    Posted 13 Aug 2010 Link to this post

    I'm having this problem:

    To duplicate it, try adding one of each Telerik control to a page, then open the page in IE and see if all them appear correctly.  I have a page that has several different Telerik controls (RadAjax, RadTooltip, RadTabStrip, RadDate and Time Pickers, RadEditor, etc).  If I count all of the WebResource.axd references that IE 8 is making, it's over 30.  If I remove a couple Telerik controls, then the remaining controls get their style back.

    They all appear perfect in Firefox 3.6.8, Chrome and Safari, so I know it's an IE 8 issue.  Is Telerik aware of this?  Is there any way around this?
  2. Answer
    Kamen Bundev
    Kamen Bundev avatar
    1532 posts

    Posted 16 Aug 2010 Link to this post

    Hi MJ,

    Yes, we are aware of this and working to implement some changes in our RadStylesheetManager to work around this. Until then, check this blog post about the problem (and another one) and how to work around it yourself (there are several ways). Unfortunately Microsoft is not going to fix both issues in the next IE9 release, so they are here to stay.

    Best wishes,
    Kamen Bundev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. DevCraft R3 2016 release webinar banner
Back to Top