Tick Not showing properly in IE7

3 posts, 1 answers
  1. Amol
    Amol avatar
    57 posts
    Member since:
    Apr 2008

    Posted 30 Sep 2009 Link to this post

    Hello Team,

    Please let me know if there any way for displaying proper ticks in IE7

    Because it will truncate the last tick as ("10") instead of ("100")  
    I need the exact width of RadSlider as mentioned below.  
    please see the example below in IE 7 and it is working fine in FF and IE 8
    <telerik:RadSlider runat="server" ID="sldLongResume" Orientation="Horizontal" ItemType="Tick" 
            SmallChange="1" LargeChange="50" Height="30px" ShowDragHandle="false" Width="97px" 
            IsSelectionRangeEnabled="true" TrackPosition="BottomRight" ShowDecreaseHandle="false" 
            ShowIncreaseHandle="false" Enabled="false" /> 



    Thanks
    Amol
  2. Answer
    Tsvetie
    Admin
    Tsvetie avatar
    1517 posts

    Posted 02 Oct 2009 Link to this post

    Hello Amol,
    The problem in this case is a result of the Enabled="false" setting. In this case, the slider uses filter for IE and opacity for the other browsers to make the RadSlider look disabled. In this case however, the child elements of an element with filter cannot overflow the element itself. In case you remove the filter, the problem will be solved, but the slider will not look disabled:
    <head runat="server"
        <title></title
        <style type="text/css"
            .RadSlider .rslDisabled 
            { 
                filter: none !important; 
            } 
        </style> 
    </head> 
    <body> 
        <form id="form1" runat="server"
        <asp:ScriptManager ID="ScriptManager1" runat="server"
        </asp:ScriptManager> 
        <telerik:RadSlider runat="server" ID="sldLongResume" Orientation="Horizontal" ItemType="Tick" 
            SmallChange="1" LargeChange="50" Height="30px" ShowDragHandle="false" Width="97px" 
            IsSelectionRangeEnabled="true" TrackPosition="BottomRight" ShowDecreaseHandle="false" 
            ShowIncreaseHandle="false" Enabled="false" /> 
        </form> 
    </body> 

    Sincerely yours,
    Tsvetie
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  3. UI for ASP.NET Ajax is Ready for VS 2017
  4. Amol
    Amol avatar
    57 posts
    Member since:
    Apr 2008

    Posted 05 Oct 2009 Link to this post

    Hi Tsvetie ,

    Thank you very much for Quick reply.

    Its working for IE 7.
Back to Top