'~/Telerik.Web.UI.WebResource.axd' is missing in web.config

12 posts, 0 answers
  1. Jo
    Jo avatar
    4 posts
    Member since:
    Sep 2012

    Posted 11 Sep 2012 Link to this post

    I get this error using Sitecore:

    '~/Telerik.Web.UI.WebResource.axd' is missing in web.config. RadScriptManager requires a HttpHandler registration in web.config. Please, use the control Smart Tag to add the handler automatically, or see the help for more information: Controls > RadScriptManager

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.InvalidOperationException: '~/Telerik.Web.UI.WebResource.axd' is missing in web.config. RadScriptManager requires a HttpHandler registration in web.config. Please, use the control Smart Tag to add the handler automatically, or see the help for more information: Controls > RadScriptManager

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [InvalidOperationException: '~/Telerik.Web.UI.WebResource.axd' is missing in web.config. RadScriptManager requires a HttpHandler registration in web.config. Please, use the control Smart Tag to add the handler automatically, or see the help for more information: Controls > RadScriptManager]
       Telerik.Web.UI.RadScriptManager.OnPreRender(EventArgs e) +161
       System.Web.UI.Control.PreRenderRecursiveInternal() +80
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Control.PreRenderRecursiveInternal() +171
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +842
    



    I have tried adding lines like this with the correct versions for my DLLs:
            <add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2010.2.826.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false" />

    I have this at the moment:
    <add verb="*" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" />

    If I create a blank page and drag the control on from my toolbox I get a red message on it saying 'Error Cannot render control' so I can't get it to auto add the necessary stuff into the web.config.

    This works across our sites and on my colleagues computers but not mine.

    What is missing?

  2. Rumen
    Admin
    Rumen avatar
    12598 posts
    Member since:
    Sep 2012

    Posted 11 Sep 2012 Link to this post

    Hi,

    These are the handlers needed for RadEditor and RadScriptManager:

    <httpHandlers>
          <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false"/>
          <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false"/>
          <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false"/>
    </httpHandlers>

    and

    <system.webServer>
        <modules runAllManagedModulesForAllRequests="true"/>
        <validation validateIntegratedModeConfiguration="false"/>
        <handlers>
          <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler"/>
          <add name="Telerik_Web_UI_SpellCheckHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler"/>
          <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource"/>
        </handlers>
      </system.webServer>

    It is not needed to specify fully qualified names and I do not recommend you to set them to avoid versioning problems.


    All the best,
    Rumen
    the Telerik team

    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.

  3. DevCraft Release
  4. Jo
    Jo avatar
    4 posts
    Member since:
    Sep 2012

    Posted 11 Sep 2012 Link to this post

    I tried these with no luck - I get exactly the same error. It was pretty much what we had anyway.

    Would there be anything else that would be causing this?

  5. Jo
    Jo avatar
    4 posts
    Member since:
    Sep 2012

    Posted 12 Sep 2012 Link to this post

    Still broken - any ideas!?

  6. Rumen
    Admin
    Rumen avatar
    12598 posts
    Member since:
    Sep 2012

    Posted 12 Sep 2012 Link to this post

    Hi,

    You can try the following:

    Add a <location> section to the application configuration file to allow access to Telerik.Web.UI.WebResource.axd to all users, like:

    Copy Code
    <configuration>
    ...
    <location path="Telerik.Web.UI.WebResource.axd">
       <system.web>
         <authorization>
           <allow users="*"/>
         </authorization>
       </system.web>
     </location>
    ...
    </configuration>


    You can also check this forum thread on the subject: IIS7 and Telerik.Web.UI.WebResource.axd' is missing in web.config and this online resource Resolving the error: ~/Telerik.Web.UI.WebResource.axd is missing in web.config.

    Regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.

  7. Jo
    Jo avatar
    4 posts
    Member since:
    Sep 2012

    Posted 13 Sep 2012 Link to this post

    Changing from integrated to classic fixed it.

    Thank you so much for the help! Very much appreciated. =)

  8. Nhat
    Nhat avatar
    1 posts
    Member since:
    Dec 2012

    Posted 29 Dec 2012 Link to this post

    Thanks Rumen
    You are Genius!!

  9. Daniel
    Daniel avatar
    6 posts
    Member since:
    Jan 2012

    Posted 28 Feb Link to this post

    that httpHandlers tag needs to go INSIDE of system.web in the web.config file***

  10. Ianko
    Admin
    Ianko avatar
    726 posts
    Member since:
    Jun 2013

    Posted 04 Mar Link to this post

    Hello Daniel,

    Yes, the httpHandlers should be placed in the system.web section and the handlers - in system.webServer. You can find additional information on this matter in this KB article.

    Regards,
    Ianko
    Telerik

    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the UI for ASP.NET AJAX, subscribe to the blog feed now.

  11. Jason
    Jason avatar
    1 posts
    Member since:
    Feb 2012

    Posted 06 Jun Link to this post

    The problem we had was that our entire site was configured in a location node in the web.config so that child apps wouldn't get the settings.

    <location path="." inheritInChildApplications="false">

    Looks like the issue is that the registration of the handlers in the handler sections within that location node was not being detected by the script manager and it throws the error, even though they are registered.

    The fix I found, that doesn't require changing to Classic pipeline, is to set the EnableHandlerDetection property to false on the RadScriptManager

  12. Tom
    Tom avatar
    1 posts
    Member since:
    Jun 2014

    Posted 24 Jun in reply to Rumen Link to this post

    I had added the httpHandlers and system.webServer handlers above, along with this <location> section in my web.config after running across this forum, but this was not enough.

    I then installed the Telerik.Web.UI (2013_3_1015) and Telerik Extensions for ASPNET MVC (2013_2_611), and when I re-launched my web project in Visual Studio 2010, a Telerik notice saying my web.config's extensions were out of date asked if I wanted it to re-write the web.config to take advantage of the new extensions.  I told the wizard to do this and checked the box to copy in the referenced DLLs to the project.  I did a build, publish, and the site finally came up with no error. 

    I did a "diff" on the web.config from the previous version.  It had the changes mentioned here, but quite a few more:

        -  <compliation> tag now has strict=false and explicit=true
        -  In httpHandlers, Telerik.Web.UI.WebResource.axd's type resource no longer has ", Telerik.Web.UI" in addition to "Telerik.Web.UI.WebResource" -- only the latter remains.
        -  Additional httpHandlers were added: 

    <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false" />
    <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
    <add path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" validate="false" /> 

        -  Additional <handlers> in <system.webServer> have been created:

    <add name="ChartImage_axd" path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" preCondition="integratedMode" />
    <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.aspx" type="Telerik.Web.UI.SpellCheckHandler" verb="*" preCondition="integratedMode" />
    <add name="Telerik_Web_UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" preCondition="integratedMode"  />
    <add name="Telerik_RadUploadProgressHandler_ashx" path="Telerik.RadUploadProgressHandler.ashx" type="Telerik.Web.UI.RadUploadProgressHandler" verb="*" preCondition="integratedMode"  />
    <add name="Telerik_Web_UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" preCondition="integratedMode" />

    And, at the end of <system.webServer>, this <modules> tag has been inserted:

    <modules runAllManagedModulesForAllRequests="true">
    <remove name="RadCompression" />
    <add name="RadCompression" type="Telerik.Web.UI.RadCompression" preCondition="integratedMode" /></modules>

    There were other "remove name" tags like that in the httpHandlers and system.webServer handlers for each value, too.

    So you may be able to edit your web.config manually, like above, and add that <location> piece, or install the extension tools and latest Telerik.Web.UI and have the system re-write your web.config for you.

    Hopefully all of this may help someone.











  13. VEERANAN
    VEERANAN avatar
    1 posts
    Member since:
    Sep 2014

    Posted 15 Sep in reply to Rumen Link to this post

    super really it is very helpful thanks

Back to Top
DevCraft Release